aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-06-06 14:31:01 +0200
committerFelix Fietkau <nbd@nbd.name>2021-06-12 10:46:39 +0200
commit97258f53634d7237a2962aec3387f011047ce83b (patch)
tree24966f800bdf95b4f3ef3126772f5017c78c0c2e /tools/Makefile
parenta85aaa1bc299301ad741b6ef94d7580c9095f1be (diff)
downloadupstream-97258f53634d7237a2962aec3387f011047ce83b.tar.gz
upstream-97258f53634d7237a2962aec3387f011047ce83b.tar.bz2
upstream-97258f53634d7237a2962aec3387f011047ce83b.zip
build: add ninja build tool and make it available for cmake
ninja is faster at building cmake packages than make, and according to reports also more reliable at handling parallel builds This commit includes a patch that adds GNU make jobserver support, in order to allow more precise control over the number of parallel tasks Enable parallel build by default for packages using ninja Signed-off-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 8752a3e2b5..47a82fd237 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -24,7 +24,7 @@ endif
tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
tools-y += libressl libtool lzma m4 make-ext4fs missing-macros mkimage
-tools-y += mklibs mm-macros mtd-utils mtools padjffs2 patch-image
+tools-y += mklibs mm-macros mtd-utils mtools ninja padjffs2 patch-image
tools-y += patchelf pkgconf quilt squashfskit4 sstrip xxd zip zlib zstd
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl