aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2018-12-12 16:10:42 +0100
committerAlexander Couzens <lynxis@fe80.eu>2019-02-28 01:38:46 +0100
commit889b6423b78bcde8af81d68a3fabcdd019181de4 (patch)
tree1855cb252ea7297bb74901a9955a33347512ebc0 /tools/Makefile
parent9e8cbecb7f188dcf31b3a4e268d8e2b8e6d55a58 (diff)
downloadupstream-889b6423b78bcde8af81d68a3fabcdd019181de4.tar.gz
upstream-889b6423b78bcde8af81d68a3fabcdd019181de4.tar.bz2
upstream-889b6423b78bcde8af81d68a3fabcdd019181de4.zip
tools: migrate from squashfs4 to squashfskit4
squashfskit is a fork of the squashfs-tools. squashfskit creates reproducible filesystems and includes many of the distro patches. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Tested-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 0123a759c8..d9f92d5bd0 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -33,7 +33,7 @@ tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
tools-$(CONFIG_TARGET_ar71xx) += lzma-old
tools-$(CONFIG_TARGET_ar71xx)$(CONFIG_TARGET_ath79) += squashfs
tools-$(CONFIG_USES_MINOR) += kernel2minor
-tools-y += lzma squashfs4 zip
+tools-y += lzma squashfskit4 zip
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl
tools-$(CONFIG_USE_SPARSE) += sparse
@@ -44,7 +44,7 @@ $(curdir)/bison/compile := $(curdir)/flex/compile
$(curdir)/flex/compile := $(curdir)/libtool/compile
$(curdir)/libtool/compile := $(curdir)/m4/compile $(curdir)/autoconf/compile $(curdir)/automake/compile $(curdir)/missing-macros/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
-$(curdir)/squashfs4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
+$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
$(curdir)/quilt/compile := $(curdir)/autoconf/compile $(curdir)/findutils/compile
$(curdir)/autoconf/compile := $(curdir)/m4/compile
$(curdir)/automake/compile := $(curdir)/m4/compile $(curdir)/autoconf/compile $(curdir)/pkg-config/compile $(curdir)/xz/compile