aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-06 13:15:14 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-06 14:12:46 +0200
commit575d3865908bf46568e6ee039ca47cf517abd9ee (patch)
tree5da7df8ff4917772d6719af774591ff0f2e65f2d /tools/Makefile
parentadb156600966ed7629471688c81f18cf893ef452 (diff)
downloadupstream-575d3865908bf46568e6ee039ca47cf517abd9ee.tar.gz
upstream-575d3865908bf46568e6ee039ca47cf517abd9ee.tar.bz2
upstream-575d3865908bf46568e6ee039ca47cf517abd9ee.zip
tools: make all tools depend on xz
Make all tools except tar (which is required to bootstrap xz-utils) and XZ itself depend on XZ, in order to be able to handle .tar.xz downloads. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 1708c9a5b0..186c6c4645 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -97,6 +97,9 @@ endif
# dependency for tools which have patches directory
$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
+# make any tool (except xz itself) depend on XZ to ensure that *.tar.xz source archives can be unpacked
+$(foreach tool, $(filter-out xz,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/xz/install))
+
$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
tools-y += tar