aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-23 01:16:17 -0800
committerHans Dedecker <dedeckeh@gmail.com>2020-12-31 10:03:21 +0100
commit31554e50d2c3d0707a40f9ed08b0d6999f584ba2 (patch)
tree59fde8c27d0a816ab8d63c4975e190bb75f912bc /tools/Makefile
parentf3e45c45cba1a541693da840642b08226653dff4 (diff)
downloadupstream-31554e50d2c3d0707a40f9ed08b0d6999f584ba2.tar.gz
upstream-31554e50d2c3d0707a40f9ed08b0d6999f584ba2.tar.bz2
upstream-31554e50d2c3d0707a40f9ed08b0d6999f584ba2.zip
ccache: update to 4.1
Upstream switched to building with CMake. Adjust accordingly. Reapplied patch as upstream changed the file format. Added HOST_BUILD_PARALLEL for faster compilation. Added cmake tool dependency and removed circular dependencies as a result. Adjusted dependent tools to use NOCACHE as they are needed to build ccache. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index c66d4fb991..4bef951c46 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -80,8 +80,9 @@ ifneq ($(HOST_OS),Linux)
endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
-$(foreach tool, $(filter-out xz patch,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
+$(foreach tool, $(filter-out xz zstd patch pkgconf libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
+$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
endif
# in case there is no patch tool on the host we need to make patch tool a