aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-13 17:56:40 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-03-14 13:20:06 +0000
commit0a06fcf608ddf1f5db389decf266283392344784 (patch)
treec2672e54b7a4fa5389ab41c7343561ccf05f7ce0 /tools/Makefile
parent32726846c85985fbc320d123a7b26b32124cd47a (diff)
downloadupstream-0a06fcf608ddf1f5db389decf266283392344784.tar.gz
upstream-0a06fcf608ddf1f5db389decf266283392344784.tar.bz2
upstream-0a06fcf608ddf1f5db389decf266283392344784.zip
build: fix kernel 5.4 on macos
As part of the kernel build process there are utilities built to run on the host system that expect linux kernel headers to be available. Unfortunately macos/darwin doesn't have these headers. vdso2c requires types.h so provide a minimal stub to satisfy it. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 3c37316b96..02556d4b83 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -138,6 +138,10 @@ $(STAGING_DIR_HOST)/.prepared: $(TMP_DIR)/.build
mkdir -p $(BUILD_DIR_HOST)/stamp $(STAGING_DIR_HOST)/include/sys
$(INSTALL_DATA) $(TOPDIR)/tools/include/*.h $(STAGING_DIR_HOST)/include/
$(INSTALL_DATA) $(TOPDIR)/tools/include/sys/*.h $(STAGING_DIR_HOST)/include/sys/
+ifneq ($(HOST_OS),Linux)
+ mkdir -p $(STAGING_DIR_HOST)/include/asm
+ $(INSTALL_DATA) $(TOPDIR)/tools/include/asm/*.h $(STAGING_DIR_HOST)/include/asm/
+endif
ln -snf lib $(STAGING_DIR_HOST)/lib64
touch $@