aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-01 17:51:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-01 17:51:36 +0000
commit00d1e599d753602c18f34d9642574d70b97e607d (patch)
tree8e81bd68be8fbbb35642d243211ede63a864ee10 /tools/Makefile
parentea70b60a072edab2da2ae77e91c21f233c548eff (diff)
downloadupstream-00d1e599d753602c18f34d9642574d70b97e607d.tar.gz
upstream-00d1e599d753602c18f34d9642574d70b97e607d.tar.bz2
upstream-00d1e599d753602c18f34d9642574d70b97e607d.zip
add a command for printing a cleaned up make target database - will be used to analyze package dependencies at some point
SVN-Revision: 22871
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 6e364af7a9..5a5c728ab7 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -54,6 +54,7 @@ $(curdir)/upslug2/compile := $(curdir)/automake/install
$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)
+ifndef DUMP_TARGET_DB
define PrepareStaging
@for dir in $(1); do ( \
set -x; \
@@ -84,6 +85,7 @@ $(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
}; ln -s "$$$$FILE" "$$@"
endef
+endif
$(eval $(call PrepareCommand,find,gfind find))
$(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))