aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-04-04 18:32:30 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2021-04-17 21:56:05 +0200
commitfc093c3f9cce80ea60e3752f6629f999ec186765 (patch)
treefe52204e5f3fe7137b6ea6bdf9742186dda80b60 /toolchain
parent10aacb9a6ce3445cdee39573f4120e7888beb022 (diff)
downloadupstream-fc093c3f9cce80ea60e3752f6629f999ec186765.tar.gz
upstream-fc093c3f9cce80ea60e3752f6629f999ec186765.tar.bz2
upstream-fc093c3f9cce80ea60e3752f6629f999ec186765.zip
toolchain/gdb: fix compilation with ccache
For some reason, one of the configure checks results in some infinite loop and ends up spawning endless gcc processes, causing OOM. Just pass a configure var to avoid it. Same fix as 6e23813c1ed7494a9da3b5e59cfcafd71097c420 Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gdb/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 3bcc9d1238..05e3c7de3c 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -22,6 +22,7 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
HOST_CONFIGURE_VARS += \
+ acx_cv_cc_gcc_supports_ada=false \
gdb_cv_func_sigsetjmp=yes
HOST_CONFIGURE_ARGS = \