aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:15:12 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:15:12 +0000
commitcf7199f48b5ef5edbeca7b0d02e1c448c8e1785d (patch)
treea2eb985c3fee20ca21da2e073ff781ff0d8a33f9 /toolchain
parent0e0bf71ed982211d00813140b2c6771733ee0661 (diff)
downloadupstream-cf7199f48b5ef5edbeca7b0d02e1c448c8e1785d.tar.gz
upstream-cf7199f48b5ef5edbeca7b0d02e1c448c8e1785d.tar.bz2
upstream-cf7199f48b5ef5edbeca7b0d02e1c448c8e1785d.zip
this patch fixes toolchain parallel build, which reduces build time.
In order to enable parallel build, change line 21 of include/host-build.mk from: override MAKEFLAGS= to: override MAKEFLAGS=$(MAKE_JOBS) -Raphael SVN-Revision: 19995
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 8b920607e0..9c820f2fec 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -250,7 +250,7 @@ define SetupExtraArch
endef
define Stage2/Install
- $(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
+ $(_SINGLE)$(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
# Set up the symlinks to enable lying about target name.
set -e; \
(cd $(TOOLCHAIN_DIR)/usr; \