aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-10-12 14:42:41 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-10-12 14:42:41 +0000
commitaeb9305c5c64708ff80817a956f425d5b1dd3e00 (patch)
tree62f2f685780de5e1264ddf7a2f598e7778dccb59 /toolchain
parent7bf973ee4ed164fa451e2248531da96c0edbaeab (diff)
downloadupstream-aeb9305c5c64708ff80817a956f425d5b1dd3e00.tar.gz
upstream-aeb9305c5c64708ff80817a956f425d5b1dd3e00.tar.bz2
upstream-aeb9305c5c64708ff80817a956f425d5b1dd3e00.zip
[toolchain] gcc: add --with-long-double-128 for SPARC toolchain
This is required in order to build the final compiler. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/common.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index c18a330f34..53e4635df4 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -123,6 +123,7 @@ GCC_CONFIGURE:= \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
$(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+ $(if $(CONFIG_sparc),--with-long-double-128) \
ifeq ($(CONFIG_GCC_LLVM),)
GCC_BUILD_TARGET_LIBGCC:=y