aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-27 23:44:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-27 23:44:04 +0000
commit79987affe295be98103e5c4bda96f0eea69677c1 (patch)
tree3dece5c17db2fb1123c5e98beecdebbd6bccb91f /toolchain
parent81b82549d68221b25ea53d8a6ea497b0257ac755 (diff)
downloadupstream-79987affe295be98103e5c4bda96f0eea69677c1.tar.gz
upstream-79987affe295be98103e5c4bda96f0eea69677c1.tar.bz2
upstream-79987affe295be98103e5c4bda96f0eea69677c1.zip
fix ccache build (#1415)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6412 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/ccache/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/toolchain/ccache/Makefile b/toolchain/ccache/Makefile
index 348aed0fce..e8e85b442a 100644
--- a/toolchain/ccache/Makefile
+++ b/toolchain/ccache/Makefile
@@ -19,24 +19,31 @@ PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-ifneq ($(shell which ccache),)
- define Build/Configure
- $(call Build/Configure/Default)
- endef
-
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
define Build/Compile
- $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+ $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
endef
define Build/Install
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(STAGING_DIR)" \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(STAGING_DIR)" \
install
endef
define Build/Clean
- $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
-$(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+ endef
+else
+ define Build/Prepare
+ endef
+ define Build/Configure
+ endef
+ define Build/Compile
+ endef
+ define Build/Clean
endef
endif
+
$(eval $(call HostBuild))