aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-06 14:17:45 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-19 01:25:26 +0100
commit6e23813c1ed7494a9da3b5e59cfcafd71097c420 (patch)
tree617dab5615fa9276320c060ca0ea4bae12096ea2 /toolchain
parentf65b0afadb5398d1c1957c9b6a1c3bc735ff7a60 (diff)
downloadupstream-6e23813c1ed7494a9da3b5e59cfcafd71097c420.tar.gz
upstream-6e23813c1ed7494a9da3b5e59cfcafd71097c420.tar.bz2
upstream-6e23813c1ed7494a9da3b5e59cfcafd71097c420.zip
binutils: fix compilation with ccache
For some reason, one of the configure checks results in some infinite loop and ends up spawning endless gcc processes, causing OOM. Just pass a configure var to avoid it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index da86794480..65d9925f9a 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -63,6 +63,9 @@ ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
endif
+HOST_CONFIGURE_VARS += \
+ acx_cv_cc_gcc_supports_ada=false
+
define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)