aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-10-24 20:20:54 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-11-01 20:54:37 +0100
commit35ac91f19dedf7ddba2a82f1c96b565ac15fbaae (patch)
tree1ee499e175888cfb06ecda75ae4951c1992d141b /toolchain
parentcafa3dc7c77753e49052732aad763cb3add10aa6 (diff)
downloadupstream-35ac91f19dedf7ddba2a82f1c96b565ac15fbaae.tar.gz
upstream-35ac91f19dedf7ddba2a82f1c96b565ac15fbaae.tar.bz2
upstream-35ac91f19dedf7ddba2a82f1c96b565ac15fbaae.zip
toolchain: gdb: Update to version 10.1
gdb 10.1 adds many new features for example gdbserver support for - ARC GNU/Linux - RISC-V GNU/Linux Removed this patch, because similar changes are now integrated upstream: toolchain/gdb/patches/100-no_extern_inline.patch Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gdb/Makefile4
-rw-r--r--toolchain/gdb/patches/100-no_extern_inline.patch24
-rw-r--r--toolchain/gdb/patches/110-no_testsuite.patch10
-rw-r--r--toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch6
4 files changed, 10 insertions, 34 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 3452ac4dc7..0b4af1164b 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
-PKG_VERSION:=8.3.1
+PKG_VERSION:=10.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=1e55b4d7cdca7b34be12f4ceae651623aa73b2fd640152313f9f66a7149757c4
+PKG_HASH:=f82f1eceeec14a3afa2de8d9b0d3c91d5a3820e23e0a01bbb70ef9f0276b62c0
GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
diff --git a/toolchain/gdb/patches/100-no_extern_inline.patch b/toolchain/gdb/patches/100-no_extern_inline.patch
deleted file mode 100644
index 4036f70301..0000000000
--- a/toolchain/gdb/patches/100-no_extern_inline.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/sim/common/sim-arange.c
-+++ b/sim/common/sim-arange.c
-@@ -277,9 +277,7 @@ sim_addr_range_delete (ADDR_RANGE *ar, a
- build_search_tree (ar);
- }
-
--#else /* SIM_ARANGE_C_INCLUDED */
--
--SIM_ARANGE_INLINE int
-+int
- sim_addr_range_hit_p (ADDR_RANGE *ar, address_word addr)
- {
- ADDR_RANGE_TREE *t = ar->range_tree;
---- a/sim/common/sim-arange.h
-+++ b/sim/common/sim-arange.h
-@@ -73,7 +73,7 @@ extern void sim_addr_range_delete (ADDR_
-
- /* Return non-zero if ADDR is in range AR, traversing the entire tree.
- If no range is specified, that is defined to mean "everything". */
--SIM_ARANGE_INLINE int
-+extern int
- sim_addr_range_hit_p (ADDR_RANGE * /*ar*/, address_word /*addr*/);
- #define ADDR_RANGE_HIT_P(ar, addr) \
- ((ar)->range_tree == NULL || sim_addr_range_hit_p ((ar), (addr)))
diff --git a/toolchain/gdb/patches/110-no_testsuite.patch b/toolchain/gdb/patches/110-no_testsuite.patch
index f4a2cde5c8..90a2574caf 100644
--- a/toolchain/gdb/patches/110-no_testsuite.patch
+++ b/toolchain/gdb/patches/110-no_testsuite.patch
@@ -1,16 +1,16 @@
--- a/gdb/configure
+++ b/gdb/configure
-@@ -918,8 +918,7 @@ MAKEINFOFLAGS
+@@ -952,8 +952,7 @@ DEBUGINFOD_LIBS
YACC
YFLAGS
XMKMF'
-ac_subdirs_all='testsuite
--gdbtk
-+ac_subdirs_all='gdbtk
- gdbserver'
+-gdbtk'
++ac_subdirs_all='gdbtk'
# Initialize some variables set by options.
-@@ -6628,7 +6627,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+ ac_init_help=
+@@ -6668,7 +6667,7 @@ $as_echo "$with_auto_load_safe_path" >&6
diff --git a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
index 2b6610673c..99c91a0304 100644
--- a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -2511,7 +2511,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+--- a/gdbserver/configure
++++ b/gdbserver/configure
+@@ -2661,7 +2661,7 @@ $as_echo "$as_me: error: \`$ac_var' was
ac_cache_corrupted=: ;;
,);;
*)