aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>2020-08-25 12:03:28 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-31 22:11:23 +0200
commit21abc09cd6a106714664519283d0cb9e92ff7ef4 (patch)
treea6ab7e87f89c9be0d317ca185d06003b21e8e59d /toolchain
parent69630140ec8542c955f5be4268ff4e53c6646f89 (diff)
downloadupstream-21abc09cd6a106714664519283d0cb9e92ff7ef4.tar.gz
upstream-21abc09cd6a106714664519283d0cb9e92ff7ef4.tar.bz2
upstream-21abc09cd6a106714664519283d0cb9e92ff7ef4.zip
toolchain: Update GCC 10 to version 10.2.0
Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/10.2.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/10.1.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/010-documentation.patch (renamed from toolchain/gcc/patches/10.1.0/010-documentation.patch)2
-rw-r--r--toolchain/gcc/patches/10.2.0/110-Fix-MIPS-PR-84790.patch (renamed from toolchain/gcc/patches/10.1.0/110-Fix-MIPS-PR-84790.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/10.1.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/10.1.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/10.1.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/10.1.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/10.1.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/10.1.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/10.1.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/10.1.0/870-ppc_no_crtsavres.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/10.1.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/10.1.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/10.1.0/910-mbsd_multi.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/10.1.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/10.1.0/930-fix-mips-noexecstack.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch (renamed from toolchain/gcc/patches/10.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch)0
-rw-r--r--toolchain/gcc/patches/10.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch (renamed from toolchain/gcc/patches/10.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch)0
20 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index ccc7b273fa..09deae3bf1 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -19,7 +19,7 @@ config GCC_VERSION
default "5.5.0" if GCC_VERSION_5
default "7.5.0" if GCC_VERSION_7
default "9.3.0" if GCC_VERSION_9
- default "10.1.0" if GCC_VERSION_10
+ default "10.2.0" if GCC_VERSION_10
default "8.4.0"
config GCC_USE_IREMAP
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index eb0ddbf2d9..ab312e5afd 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -44,8 +44,8 @@ ifeq ($(PKG_VERSION),9.3.0)
PKG_HASH:=71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
endif
-ifeq ($(PKG_VERSION),10.1.0)
- PKG_HASH:=b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2
+ifeq ($(PKG_VERSION),10.2.0)
+ PKG_HASH:=b8dd4368bb9c7f0b98188317ee0254dd8cc99d1e3a18d0ff146c855fe16c1d8c
endif
PATCH_DIR=../patches/$(GCC_VERSION)
diff --git a/toolchain/gcc/patches/10.1.0/002-case_insensitive.patch b/toolchain/gcc/patches/10.2.0/002-case_insensitive.patch
index 409497e5a3..409497e5a3 100644
--- a/toolchain/gcc/patches/10.1.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/10.2.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/10.1.0/010-documentation.patch b/toolchain/gcc/patches/10.2.0/010-documentation.patch
index 9783ff1ef0..85990e5acc 100644
--- a/toolchain/gcc/patches/10.1.0/010-documentation.patch
+++ b/toolchain/gcc/patches/10.2.0/010-documentation.patch
@@ -12,7 +12,7 @@ Date: Tue Feb 26 16:16:33 2013 +0000
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
-@@ -3283,18 +3283,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
+@@ -3285,18 +3285,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
doc/gccint.info: $(TEXI_GCCINT_FILES)
doc/cppinternals.info: $(TEXI_CPPINT_FILES)
diff --git a/toolchain/gcc/patches/10.1.0/110-Fix-MIPS-PR-84790.patch b/toolchain/gcc/patches/10.2.0/110-Fix-MIPS-PR-84790.patch
index 82ac013d30..82ac013d30 100644
--- a/toolchain/gcc/patches/10.1.0/110-Fix-MIPS-PR-84790.patch
+++ b/toolchain/gcc/patches/10.2.0/110-Fix-MIPS-PR-84790.patch
diff --git a/toolchain/gcc/patches/10.1.0/230-musl_libssp.patch b/toolchain/gcc/patches/10.2.0/230-musl_libssp.patch
index 63f37662f4..63f37662f4 100644
--- a/toolchain/gcc/patches/10.1.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/10.2.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/10.1.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/10.2.0/300-mips_Os_cpu_rtx_cost_model.patch
index 8c4a5fce19..8c4a5fce19 100644
--- a/toolchain/gcc/patches/10.1.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/10.2.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/10.1.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/10.2.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/10.1.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/10.2.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/10.1.0/820-libgcc_pic.patch b/toolchain/gcc/patches/10.2.0/820-libgcc_pic.patch
index ddd6cf8732..ddd6cf8732 100644
--- a/toolchain/gcc/patches/10.1.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/10.2.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/10.1.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/10.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
index e3cb616c4e..e3cb616c4e 100644
--- a/toolchain/gcc/patches/10.1.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/10.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/10.1.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/10.2.0/850-use_shared_libgcc.patch
index 8b17f1374f..8b17f1374f 100644
--- a/toolchain/gcc/patches/10.1.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/10.2.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/10.1.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/10.2.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/10.1.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/10.2.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/10.1.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/10.2.0/870-ppc_no_crtsavres.patch
index bc182f0cec..bc182f0cec 100644
--- a/toolchain/gcc/patches/10.1.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/10.2.0/870-ppc_no_crtsavres.patch
diff --git a/toolchain/gcc/patches/10.1.0/881-no_tm_section.patch b/toolchain/gcc/patches/10.2.0/881-no_tm_section.patch
index 2029910fd0..2029910fd0 100644
--- a/toolchain/gcc/patches/10.1.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/10.2.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/10.1.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/10.2.0/900-bad-mips16-crt.patch
index dd6e9dc889..dd6e9dc889 100644
--- a/toolchain/gcc/patches/10.1.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/10.2.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/10.1.0/910-mbsd_multi.patch b/toolchain/gcc/patches/10.2.0/910-mbsd_multi.patch
index 452cc1cb4e..452cc1cb4e 100644
--- a/toolchain/gcc/patches/10.1.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/10.2.0/910-mbsd_multi.patch
diff --git a/toolchain/gcc/patches/10.1.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/10.2.0/920-specs_nonfatal_getenv.patch
index 487b9e47cb..487b9e47cb 100644
--- a/toolchain/gcc/patches/10.1.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/10.2.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/10.1.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/10.2.0/930-fix-mips-noexecstack.patch
index e795acd1de..e795acd1de 100644
--- a/toolchain/gcc/patches/10.1.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/10.2.0/930-fix-mips-noexecstack.patch
diff --git a/toolchain/gcc/patches/10.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch b/toolchain/gcc/patches/10.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
index fb4cb1533a..fb4cb1533a 100644
--- a/toolchain/gcc/patches/10.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
+++ b/toolchain/gcc/patches/10.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
diff --git a/toolchain/gcc/patches/10.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch b/toolchain/gcc/patches/10.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
index b1d7576328..b1d7576328 100644
--- a/toolchain/gcc/patches/10.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
+++ b/toolchain/gcc/patches/10.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch