aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-06 17:10:45 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-06 17:10:45 +0000
commit10d11328effd162340acc9b30b943dc98bf80f18 (patch)
tree1b93acdda79ab4d733c47e22c46c7a42d0c65098 /toolchain
parent2e757a66926139cd14e33d808ff369b5bc4360fc (diff)
downloadupstream-10d11328effd162340acc9b30b943dc98bf80f18.tar.gz
upstream-10d11328effd162340acc9b30b943dc98bf80f18.tar.bz2
upstream-10d11328effd162340acc9b30b943dc98bf80f18.zip
gcc: only enable/disable TLS support in final stage (closes: #6788)
SVN-Revision: 20018
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 9c820f2fec..9536cc245b 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -116,11 +116,6 @@ else
--disable-libssp
endif
-ifeq ($(CONFIG_TLS_SUPPORT),)
- GCC_CONFIGURE+= \
- --disable-tls
-endif
-
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
GCC_CONFIGURE+= \
--enable-biarch \
@@ -159,6 +154,14 @@ GCC_CONFIGURE_STAGE2:= \
--enable-threads \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+ifneq ($(CONFIG_TLS_SUPPORT),)
+ GCC_CONFIGURE_STAGE2+= \
+ --enable-tls
+else
+ GCC_CONFIGURE_STAGE2+= \
+ --disable-tls
+endif
+
ifdef CONFIG_powerpc
TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
endif