aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/wrapper
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-02-20 15:06:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-02-20 15:06:10 +0000
commit9622f68581cea9d607bbd641b89350c2420720d5 (patch)
treec5bce9c0e9c3c31376ed6bec317a21ddb008e427 /toolchain/wrapper
parent330ae61b1b8e136b268d2a9316e434a6ca842979 (diff)
downloadupstream-9622f68581cea9d607bbd641b89350c2420720d5.tar.gz
upstream-9622f68581cea9d607bbd641b89350c2420720d5.tar.bz2
upstream-9622f68581cea9d607bbd641b89350c2420720d5.zip
buildroot: allow specifying libc personality for external toolchains
SVN-Revision: 35703
Diffstat (limited to 'toolchain/wrapper')
-rw-r--r--toolchain/wrapper/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/wrapper/Makefile b/toolchain/wrapper/Makefile
index 417ed8cd37..3398e407c9 100644
--- a/toolchain/wrapper/Makefile
+++ b/toolchain/wrapper/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/toolchain-build.mk
define toolchain_util
$(strip $(SCRIPT_DIR)/ext-toolchain.sh --toolchain $(CONFIG_TOOLCHAIN_ROOT) \
--cflags $(CONFIG_TARGET_OPTIMIZATION) \
- --cflags "-muclibc $(if $(CONFIG_SOFT_FLOAT),-msoft-float)" \
+ --cflags "$(if $(call qstrip,$(CONFIG_TOOLCHAIN_LIBC)),-m$(call qstrip,$(CONFIG_TOOLCHAIN_LIBC))) $(if $(CONFIG_SOFT_FLOAT),-msoft-float)" \
--cflags "$(patsubst ./%,-I$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_INC_PATH)))" \
--cflags "$(patsubst ./%,-L$(TOOLCHAIN_ROOT_DIR)/%,$(call qstrip,$(CONFIG_TOOLCHAIN_LIB_PATH)))" \
$(1))