aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-07-14 23:24:58 +0000
committerNicolas Thill <nico@openwrt.org>2008-07-14 23:24:58 +0000
commit89eb716470a2262ccb855d7402711b940805ef20 (patch)
tree4f94fe05b3183dbc83fc7c9c2b42f9a08d7edfab /toolchain/uClibc
parent3890bd2126a29b85aabbda3fc4311736640ff5fa (diff)
downloadupstream-89eb716470a2262ccb855d7402711b940805ef20.tar.gz
upstream-89eb716470a2262ccb855d7402711b940805ef20.tar.bz2
upstream-89eb716470a2262ccb855d7402711b940805ef20.zip
use qstrip macro to strip quoted CONFIG_* strings
SVN-Revision: 11832
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index e6f2b7b191..8c02489b14 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=uClibc
-PKG_VERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION)))#"))
-PKG_EXTRAVERSION:=$(strip $(subst ",, $(CONFIG_UCLIBC_EXTRA_VERSION)))#"))
-PKG_VERSION_SNAPSHOT:=$(strip $(subst ",, $(CONFIG_UCLIBC_VERSION_SNAPSHOT)))#"))
+PKG_VERSION:=$(call qstrip,$(CONFIG_UCLIBC_VERSION))
+PKG_EXTRAVERSION:=$(call qstrip,$(CONFIG_UCLIBC_EXTRA_VERSION))
+PKG_VERSION_SNAPSHOT:=$(call qstrip,$(CONFIG_UCLIBC_VERSION_SNAPSHOT))
ifeq ($(PKG_VERSION_SNAPSHOT),y)
PKG_SOURCE_URL:=http://www.uclibc.org/downloads/snapshots
else