aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/sstrip/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 06:19:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 06:19:43 +0000
commit13078b79e500d9cb914b29c9d6a8a54185fe213c (patch)
treee2cb8f4754b0d67846b3be0dfc38c64e83bffd78 /toolchain/sstrip/Makefile
parent4da6c416ff6122d03e5f3ce6808e15e761e91564 (diff)
downloadupstream-13078b79e500d9cb914b29c9d6a8a54185fe213c.tar.gz
upstream-13078b79e500d9cb914b29c9d6a8a54185fe213c.tar.bz2
upstream-13078b79e500d9cb914b29c9d6a8a54185fe213c.zip
massive cleanup of toolchain/
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4038 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/sstrip/Makefile')
-rw-r--r--toolchain/sstrip/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/toolchain/sstrip/Makefile b/toolchain/sstrip/Makefile
new file mode 100644
index 0000000000..aa18e21c5f
--- /dev/null
+++ b/toolchain/sstrip/Makefile
@@ -0,0 +1,23 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_BUILD_DIR := $(TOOL_BUILD_DIR)/sstrip
+
+OS:=$(shell uname)
+ifeq ($(OS),Darwin)
+CFLAGS += -I./include
+endif
+
+define Build/Compile
+ $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+endef
+
+define Build/Install
+ $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR)/bin
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/bin/sstrip
+endef
+
+$(eval $(call HostBuild))