aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/squashfs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-09-27 14:06:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-09-27 14:06:46 +0000
commita723361df9cb4cb58d7e806218d98df72d57cdae (patch)
treedc35000b8b3ff329b1029e8563aab31aaba9f98b /toolchain/squashfs
parent0199c0e95cfbd490a1c39ac744fdb68149c73977 (diff)
downloadupstream-a723361df9cb4cb58d7e806218d98df72d57cdae.tar.gz
upstream-a723361df9cb4cb58d7e806218d98df72d57cdae.tar.bz2
upstream-a723361df9cb4cb58d7e806218d98df72d57cdae.zip
move tools from toolchain/ to tools/
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4866 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/squashfs')
-rw-r--r--toolchain/squashfs/Makefile34
-rw-r--r--toolchain/squashfs/patches/100-lzma.patch25
2 files changed, 0 insertions, 59 deletions
diff --git a/toolchain/squashfs/Makefile b/toolchain/squashfs/Makefile
deleted file mode 100644
index 8e37a15215..0000000000
--- a/toolchain/squashfs/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=squashfs
-PKG_VERSION:=3.0
-
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/squashfs
-PKG_MD5SUM:=9fd05d0bfbb712f5fb95edafea5bc733
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)/squashfs-tools mksquashfs-lzma LZMAPATH=$(STAGING_DIR)/host/lib
-endef
-
-define Build/Install
- mkdir -p $(STAGING_DIR)/bin
- $(CP) $(PKG_BUILD_DIR)/squashfs-tools/mksquashfs-lzma $(STAGING_DIR)/bin/
-endef
-
-define Build/Clean
- rm -f $(STAGING_DIR)/bin/mksquashfs-lzma
-endef
-
-$(eval $(call HostBuild))
diff --git a/toolchain/squashfs/patches/100-lzma.patch b/toolchain/squashfs/patches/100-lzma.patch
deleted file mode 100644
index 85aa21fb92..0000000000
--- a/toolchain/squashfs/patches/100-lzma.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Nur squashfs3.0/squashfs-tools/Makefile squashfs3.0-owrt/squashfs-tools/Makefile
---- squashfs3.0/squashfs-tools/Makefile 2006-03-15 22:36:20.000000000 +0100
-+++ squashfs3.0-owrt/squashfs-tools/Makefile 2006-03-21 11:14:08.000000000 +0100
-@@ -1,4 +1,5 @@
- INCLUDEDIR = .
-+#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
-
- CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2
-
-@@ -7,6 +8,9 @@
- mksquashfs: mksquashfs.o read_fs.o sort.o
- $(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
-
-+mksquashfs-lzma: mksquashfs.o read_fs.o sort.o
-+ $(CXX) mksquashfs.o read_fs.o sort.o -L$(LZMAPATH) -llzma -o $@
-+
- mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
-
- read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
-@@ -17,3 +21,5 @@
- $(CC) unsquashfs.o -lz -o $@
-
- unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
-+
-+clean: