aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/nasm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-07 14:50:51 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-07 14:53:26 +0200
commitd3a7587eb95e6e8c85ff0e57504bc31d1e1b8523 (patch)
tree5c3307cbd408a84ae99972d4357d47c469c1e56c /toolchain/nasm
parentbf136c637c02c154c14bbf48ac2c07467d948ac7 (diff)
downloadupstream-d3a7587eb95e6e8c85ff0e57504bc31d1e1b8523.tar.gz
upstream-d3a7587eb95e6e8c85ff0e57504bc31d1e1b8523.tar.bz2
upstream-d3a7587eb95e6e8c85ff0e57504bc31d1e1b8523.zip
toolchain/nasm: fix missing AR/RANLIB variables
Fixes build on macOS Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/nasm')
-rw-r--r--toolchain/nasm/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/toolchain/nasm/Makefile b/toolchain/nasm/Makefile
index a39c71f65f..8d071033c7 100644
--- a/toolchain/nasm/Makefile
+++ b/toolchain/nasm/Makefile
@@ -24,6 +24,10 @@ HOST_CONFIGURE_ARGS+= \
--disable-gdb \
$(SOFT_FLOAT_CONFIG_OPTION) \
+HOST_MAKE_FLAGS = \
+ AR=ar \
+ RANLIB=ranlib
+
define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
@@ -37,12 +41,9 @@ define Host/Configure
$(call Host/Configure/Default)
endef
-define Host/Compile
- +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) all
-endef
-
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) \
+ $(HOST_MAKE_FLAGS) \
prefix=$(TOOLCHAIN_DIR) \
install
endef