aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/nasm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-10 13:08:30 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-10 13:09:57 +0200
commita5188eb2584c244246f2be638a54bc458ecfc497 (patch)
treecfb0c7b4e5fb54e4c63502a4c2d3580b4bc900de /toolchain/nasm
parent98a6bee09a87262da7c5c61874c565f53ee42d35 (diff)
downloadupstream-a5188eb2584c244246f2be638a54bc458ecfc497.tar.gz
upstream-a5188eb2584c244246f2be638a54bc458ecfc497.tar.bz2
upstream-a5188eb2584c244246f2be638a54bc458ecfc497.zip
nasm: disable LTO, remove host specific workarounds
The recent build failures on various platforms were apparently caused by the fact that LTO build support in the configure script does not check if it has a suitable version of gcc and simply assumes that gcc-ar is available and can be used for intermediate files. Since we really don't need to build nasm with LTO, simply disable it and keep the whole build more portable Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/nasm')
-rw-r--r--toolchain/nasm/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/toolchain/nasm/Makefile b/toolchain/nasm/Makefile
index 31166358fd..53b7848caf 100644
--- a/toolchain/nasm/Makefile
+++ b/toolchain/nasm/Makefile
@@ -19,17 +19,11 @@ include $(INCLUDE_DIR)/toolchain-build.mk
HOST_CONFIGURE_ARGS+= \
--target=$(REAL_GNU_TARGET_NAME) \
--with-sysroot=$(TOOLCHAIN_DIR) \
- --enable-lto \
+ --disable-lto \
--disable-werror \
--disable-gdb \
$(SOFT_FLOAT_CONFIG_OPTION) \
-ifeq ($(HOST_OS),Darwin)
- HOST_MAKE_FLAGS = \
- AR=ar \
- RANLIB=ranlib
-endif
-
define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)