aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/nasm
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2019-05-11 01:25:12 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-05-11 01:30:00 +0200
commit9cb3a3255e024183a2e179fe6621cd11fa6b8670 (patch)
treeabffeca53f147b85563b95e51432e5e146107e99 /toolchain/nasm
parent367813b9b17c50b9e1bc25933a3ccd252c0813e4 (diff)
downloadupstream-9cb3a3255e024183a2e179fe6621cd11fa6b8670.tar.gz
upstream-9cb3a3255e024183a2e179fe6621cd11fa6b8670.tar.bz2
upstream-9cb3a3255e024183a2e179fe6621cd11fa6b8670.zip
toolchain/nasm: update to version 2.14
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'toolchain/nasm')
-rw-r--r--toolchain/nasm/Makefile4
-rw-r--r--toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch15
2 files changed, 2 insertions, 17 deletions
diff --git a/toolchain/nasm/Makefile b/toolchain/nasm/Makefile
index 53b7848caf..3efcc86203 100644
--- a/toolchain/nasm/Makefile
+++ b/toolchain/nasm/Makefile
@@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nasm
-PKG_VERSION:=2.13.03
+PKG_VERSION:=2.14
PKG_SOURCE_URL:=https://www.nasm.us/pub/nasm/releasebuilds/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=812ecfb0dcbc5bd409aaa8f61c7de94c5b8752a7b00c632883d15b2ed6452573
+PKG_HASH:=97c615dbf02ef80e4e2b6c385f7e28368d51efc214daa98e600ca4572500eec0
HOST_BUILD_PARALLEL:=1
diff --git a/toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch b/toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch
deleted file mode 100644
index a6c5027bec..0000000000
--- a/toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/include/nasmlib.h
-+++ b/include/nasmlib.h
-@@ -188,11 +188,9 @@ int64_t readnum(char *str, bool *error);
- int64_t readstrnum(char *str, int length, bool *warn);
-
- /*
-- * seg_init: Initialise the segment-number allocator.
- * seg_alloc: allocate a hitherto unused segment number.
- */
--void pure_func seg_init(void);
--int32_t pure_func seg_alloc(void);
-+int32_t seg_alloc(void);
-
- /*
- * many output formats will be able to make use of this: a standard