aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-05 19:01:02 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-09 12:35:31 +0100
commit981be0c3bd96ccf0636bb473f21403319e4b2742 (patch)
tree9f9ea99bb98357dac6caceafa4850349b04186f6 /toolchain/musl
parent6bcc1c5331c797004e1b43168eb116d2d14b0102 (diff)
downloadupstream-981be0c3bd96ccf0636bb473f21403319e4b2742.tar.gz
upstream-981be0c3bd96ccf0636bb473f21403319e4b2742.tar.bz2
upstream-981be0c3bd96ccf0636bb473f21403319e4b2742.zip
toolchain/musl: update to version 1.1.18
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/musl')
-rw-r--r--toolchain/musl/common.mk6
-rw-r--r--toolchain/musl/patches/900-iconv_size_hack.patch6
2 files changed, 6 insertions, 6 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 0a45828f79..2a61516372 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -8,13 +8,13 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=musl
-PKG_VERSION:=1.1.16
+PKG_VERSION:=1.1.18
PKG_RELEASE=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=5f7efb87a28a311ad377dd26adf53715dedb096d
-PKG_MIRROR_HASH:=da18ef24f270e5cae6bc4c440479da17bec1949ae5a1bc990352ca04f24c4378
+PKG_SOURCE_VERSION:=eb03bde2f24582874cb72b56c7811bf51da0c817
+PKG_MIRROR_HASH:=150808458007eeb0b977059f36f88127d1a1e80ddb6ad1837b5a63efd2958e34
PKG_SOURCE_URL:=git://git.musl-libc.org/musl
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
diff --git a/toolchain/musl/patches/900-iconv_size_hack.patch b/toolchain/musl/patches/900-iconv_size_hack.patch
index 343915fb06..db18fceb17 100644
--- a/toolchain/musl/patches/900-iconv_size_hack.patch
+++ b/toolchain/musl/patches/900-iconv_size_hack.patch
@@ -32,7 +32,7 @@
static int fuzzycmp(const unsigned char *a, const unsigned char *b)
{
-@@ -216,6 +220,7 @@ size_t iconv(iconv_t cd0, char **restric
+@@ -224,6 +228,7 @@ size_t iconv(iconv_t cd0, char **restric
c = ((c-0xd7c0)<<10) + (d-0xdc00);
}
break;
@@ -40,14 +40,14 @@
case SHIFT_JIS:
if (c-0xa1 <= 0xdf-0xa1) {
c += 0xff61-0xa1;
-@@ -362,6 +367,7 @@ size_t iconv(iconv_t cd0, char **restric
+@@ -370,6 +375,7 @@ size_t iconv(iconv_t cd0, char **restric
c = ksc[c][d];
if (!c) goto ilseq;
break;
+#endif
default:
if (c < 128+type) break;
- c -= 128+type;
+ c = legacy_map(map, c);
--- a/src/locale/codepages.h
+++ b/src/locale/codepages.h
@@ -118,6 +118,7 @@