aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-01-24 16:43:28 +0100
committerFelix Fietkau <nbd@nbd.name>2018-01-25 10:54:14 +0100
commit13a5cb9d2b185a21b514af989a4fa607329a3df0 (patch)
treece13780f4c00e4fd831cf3842d51ee406e0cf0d7 /toolchain/musl
parent166741240afd396c41b284edaa5180b162232741 (diff)
downloadupstream-13a5cb9d2b185a21b514af989a4fa607329a3df0.tar.gz
upstream-13a5cb9d2b185a21b514af989a4fa607329a3df0.tar.bz2
upstream-13a5cb9d2b185a21b514af989a4fa607329a3df0.zip
musl: allow autorebuild
Autorebuild is disabled for the toolchain to avoid build-order issues. However, rebuilding musl is safe, so exclude it from that restriction. Avoids the need for manual cleaning on kernel header <-> libc API changes like the ones introduced recently Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/musl')
-rw-r--r--toolchain/musl/common.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 8350197a9f..4b53d4b556 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -21,9 +21,11 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
LIBC_SO_VERSION:=$(PKG_VERSION)
PATCH_DIR:=$(PATH_PREFIX)/patches
+BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+HOST_BUILD_PREFIX:=$(TOOLCHAIN_DIR)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
-include $(INCLUDE_DIR)/toolchain-build.mk
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/hardening.mk
MUSL_CONFIGURE:= \