aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/common.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-20 13:13:27 +0100
committerPetr Štetiar <ynezz@true.cz>2020-11-20 13:24:48 +0100
commit4d4ef1058c0f10aa2fa4070cd6b9db4d48b94148 (patch)
treee4cf5882e4101c4f7f223e76e133906d4b29a14d /toolchain/musl/common.mk
parentd36999389890fb952fc7cc8c0db8e1bbb671af12 (diff)
downloadupstream-4d4ef1058c0f10aa2fa4070cd6b9db4d48b94148.tar.gz
upstream-4d4ef1058c0f10aa2fa4070cd6b9db4d48b94148.tar.bz2
upstream-4d4ef1058c0f10aa2fa4070cd6b9db4d48b94148.zip
musl: handle wcsnrtombs destination buffer overflow (CVE-2020-28928)
The wcsnrtombs function in all musl libc versions up through 1.2.1 has been found to have multiple bugs in handling of destination buffer size when limiting the input character count, which can lead to infinite loop with no forward progress (no overflow) or writing past the end of the destination buffera. This function is not used internally in musl and is not widely used, but does appear in some applications. The non-input-limiting form wcsrtombs is not affected. All users of musl 1.2.1 and prior versions should apply the attached patch, which replaces the overly complex and erroneous implementation. The upcoming 1.2.2 release will adopt this new implementation. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'toolchain/musl/common.mk')
-rw-r--r--toolchain/musl/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 8c8eddc855..68098f5c6a 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/target.mk
PKG_NAME:=musl
PKG_VERSION:=1.1.24
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://musl.libc.org/releases/