aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/musl/common.mk
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-08-16 01:33:58 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 16:57:32 +0200
commit0d0617ff14b8b020896680de1f1a49c7ba8a5e0d (patch)
tree4d5ba8403878d68a24986dab76345009a7431da6 /toolchain/musl/common.mk
parentdc451a4b24b2096fe33eb7fa136614597cd601d5 (diff)
downloadupstream-0d0617ff14b8b020896680de1f1a49c7ba8a5e0d.tar.gz
upstream-0d0617ff14b8b020896680de1f1a49c7ba8a5e0d.tar.bz2
upstream-0d0617ff14b8b020896680de1f1a49c7ba8a5e0d.zip
musl: ldso/dlsym: fix mips returning undef dlsym
This happens only the second time a library is loaded by dlopen(). After lib1 is loaded, dlsym(lib1,"undef1") correctly resolves the undef symbol from lib1 dependencies. After the second library is loaded, dlsym(lib2,"undef1") was returning the address of "undef1" in lib2 instead of searching lib2 dependencies. Using upstream fix which now uses the same logic for relocation time and dlsym. Fixes openwrt/packages#9297 Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'toolchain/musl/common.mk')
-rw-r--r--toolchain/musl/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 4b8146ee84..8330a40b82 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/target.mk
PKG_NAME:=musl
PKG_VERSION:=1.1.23
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)