aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/mkimage/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-08-25 21:53:54 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-08-25 21:53:54 +0000
commitd5a6e89b8ff788cdcc0f195857ff042be1bf3116 (patch)
treedea67c0d50a3959429bbf0094651a6a420548313 /toolchain/mkimage/Makefile
parent13eef022bd62bc990528bdf61a705d1c96a27f11 (diff)
downloadupstream-d5a6e89b8ff788cdcc0f195857ff042be1bf3116.tar.gz
upstream-d5a6e89b8ff788cdcc0f195857ff042be1bf3116.tar.bz2
upstream-d5a6e89b8ff788cdcc0f195857ff042be1bf3116.zip
add basic support for the Magicbox boards
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4672 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/mkimage/Makefile')
-rw-r--r--toolchain/mkimage/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/mkimage/Makefile b/toolchain/mkimage/Makefile
new file mode 100644
index 0000000000..ec27e2716a
--- /dev/null
+++ b/toolchain/mkimage/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_BUILD_DIR := $(TOOL_BUILD_DIR)/mkimage
+
+define Build/Compile
+ $(CC) -O -c src/crc32.c -o $(PKG_BUILD_DIR)/crc32.o
+ $(CC) -O -c src/mkimage.c -o $(PKG_BUILD_DIR)/mkimage.o
+ $(CC) -O -o $(PKG_BUILD_DIR)/mkimage $(PKG_BUILD_DIR)/mkimage.o $(PKG_BUILD_DIR)/crc32.o
+endef
+
+define Build/Install
+ $(CP) $(PKG_BUILD_DIR)/mkimage $(STAGING_DIR)/bin
+endef
+
+define Build/Clean
+ rm -f $(STAGING_DIR)/bin/mkimage
+endef
+
+$(eval $(call HostBuild))