aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/kernel-headers
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-20 17:05:14 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-20 17:05:14 +0000
commitce5b7766e64fcd3a8c5543046d29de710996b365 (patch)
tree0c1f87a16fbf2d30904c457acc99b99b0427e9f6 /toolchain/kernel-headers
parentb5eab7140a1247e4c177aab43138d80f35b8e34f (diff)
downloadupstream-ce5b7766e64fcd3a8c5543046d29de710996b365.tar.gz
upstream-ce5b7766e64fcd3a8c5543046d29de710996b365.tar.bz2
upstream-ce5b7766e64fcd3a8c5543046d29de710996b365.zip
move all arch fixups from Install to Prepare stage, so that fixed headers are available in $(BUILD_DIR_TOOLCHAIN)/linux-dev/
SVN-Revision: 14120
Diffstat (limited to 'toolchain/kernel-headers')
-rw-r--r--toolchain/kernel-headers/Makefile69
1 files changed, 31 insertions, 38 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index 474ff6c71b..0493e2acae 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -62,18 +62,42 @@ else
define Build/Prepare/all
mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include
cp -pLR \
- $(BUILD_DIR_TOOLCHAIN)/linux/include/asm \
- $(BUILD_DIR_TOOLCHAIN)/linux/include/asm-generic \
- $(BUILD_DIR_TOOLCHAIN)/linux/include/asm-$(LINUX_KARCH) \
- $(BUILD_DIR_TOOLCHAIN)/linux/include/linux \
+ $(PKG_BUILD_DIR)/include/asm \
+ $(PKG_BUILD_DIR)/include/asm-generic \
+ $(PKG_BUILD_DIR)/include/asm-$(LINUX_KARCH) \
+ $(PKG_BUILD_DIR)/include/linux \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
endef
endif
+# XXX: the following is needed to build lzma-loader
+define Build/Prepare/lzma
+ $(CP) \
+ $(PKG_BUILD_DIR)/include/asm-mips/asm.h \
+ $(PKG_BUILD_DIR)/include/asm-mips/regdef.h \
+ $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
+endef
+
+# XXX: the following is needed to build final gcc on cris
+define Build/Prepare/post/cris
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/arch
+ $(CP) \
+ $(PKG_BUILD_DIR)/include/asm-cris/arch/ptrace.h \
+ $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/arch/
+endef
+
+define Build/Prepare/post/mips
+ $(call Build/Prepare/lzma)
+endef
+
+define Build/Prepare/post/mipsel
+ $(call Build/Prepare/lzma)
+endef
+
define Build/Prepare
$(call Kernel/Prepare/Default)
+ ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
$(SED) 's/@expr length/@-expr length/' $(PKG_BUILD_DIR)/Makefile
- ln -sf linux-$(LINUX_VERSION) $(LINUX_HEADERS_DIR)
yes '' | $(KMAKE) oldconfig
$(KMAKE) include/linux/version.h include/asm
if [ -d $(PKG_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
@@ -83,6 +107,7 @@ define Build/Prepare
fi
$(call Build/Prepare/pre/$(ARCH))
$(call Build/Prepare/all)
+ $(call Build/Prepare/post/$(ARCH))
endef
define Build/Configure
@@ -91,40 +116,8 @@ endef
define Build/Compile
endef
-define Build/Install/all
- mkdir -p $(TOOLCHAIN_DIR)/usr/include
- $(CP) \
- $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/* \
- $(TOOLCHAIN_DIR)/usr/include/
-endef
-
-# XXX: the following is needed to build lzma-loader
-define Build/Install/post/lzma
- $(CP) \
- $(BUILD_DIR_TOOLCHAIN)/linux/include/asm-mips/asm.h \
- $(BUILD_DIR_TOOLCHAIN)/linux/include/asm-mips/regdef.h \
- $(TOOLCHAIN_DIR)/usr/include/asm/
-endef
-
-# XXX: the following is needed to build final gcc on cris
-define Build/Install/post/cris
- mkdir -p $(TOOLCHAIN_DIR)/usr/include/asm/arch
- $(CP) \
- $(PKG_BUILD_DIR)/include/asm-cris/arch/ptrace.h \
- $(TOOLCHAIN_DIR)/usr/include/asm/arch/
-endef
-
-define Build/Install/post/mips
- $(call Build/Install/post/lzma)
-endef
-
-define Build/Install/post/mipsel
- $(call Build/Install/post/lzma)
-endef
-
define Build/Install
- $(call Build/Install/all)
- $(call Build/Install/post/$(ARCH))
+ $(CP) $(BUILD_DIR_TOOLCHAIN)/linux-dev/* $(TOOLCHAIN_DIR)/
endef
define Build/Clean