aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/kernel-headers
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2018-01-17 12:55:15 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-27 16:46:45 +0100
commitca7e8627dbbbcae0d1bfacea51d9b564617195de (patch)
tree2cb0403a898489b2f24781a5e9e0c0006a76af69 /toolchain/kernel-headers
parent953bf6b43d50492a96a9bac692f4d99dd804b31f (diff)
downloadupstream-ca7e8627dbbbcae0d1bfacea51d9b564617195de.tar.gz
upstream-ca7e8627dbbbcae0d1bfacea51d9b564617195de.tar.bz2
upstream-ca7e8627dbbbcae0d1bfacea51d9b564617195de.zip
kernel-headers: adjust PKG_ variables when using git clone method
When using an external git clone for the kernel repo, the build would fail because the build won't download [via git] the kernel tarball. This is because the `toolchain/kernel-headers` assumes that the kernel would get downloaded via normal HTTP. The reason for this is the `HostBuild` rule, which calls the `Download/default` rule. To use the `Download/default` we just need to conditionally adjust some PKG_ vars. We can safely use `LINUX_VERSION` as it was already adjusted in the `kernel-version.mk` to avoid collisions with other tarballs. Fixes: https://bugs.openwrt.org/index.php?do=details&task_id=503 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'toolchain/kernel-headers')
-rw-r--r--toolchain/kernel-headers/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index e374e706e1..f7842cb9bd 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -17,7 +17,13 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=linux
PKG_VERSION:=$(LINUX_VERSION)
PKG_SOURCE:=$(LINUX_SOURCE)
-PKG_SOURCE_URL:=$(LINUX_SITE)
+ifneq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ PKG_SOURCE_PROTO:=git
+ PKG_SOURCE_URL:=$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI))
+ PKG_SOURCE_VERSION:=$(CONFIG_KERNEL_GIT_REF)
+else
+ PKG_SOURCE_URL:=$(LINUX_SITE)
+endif
HOST_BUILD_DIR:=$(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
PKG_HASH:=$(LINUX_KERNEL_HASH)
LINUX_DIR := $(HOST_BUILD_DIR)