aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/kernel-headers
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commit7eb15898755be46e94078faffdacd8c9b0ce66cd (patch)
tree89dc171f7b7c646be5a38ca7d7b99e1be24fa61f /toolchain/kernel-headers
parent6ccc1c8e3c9ad0ac95c728573c300264943d8338 (diff)
downloadupstream-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.gz
upstream-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.bz2
upstream-7eb15898755be46e94078faffdacd8c9b0ce66cd.zip
build system refactoring in preparation for allowing packages to do host-build steps
SVN-Revision: 14610
Diffstat (limited to 'toolchain/kernel-headers')
-rw-r--r--toolchain/kernel-headers/Makefile96
1 files changed, 48 insertions, 48 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index cf5a384295..38e65189b3 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -21,9 +21,9 @@ PKG_NAME:=linux
PKG_VERSION:=$(LINUX_VERSION)
PKG_SOURCE:=$(LINUX_SOURCE)
PKG_SOURCE_URL:=$(LINUX_SITE)
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
+HOST_BUILD_DIR:=$(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
PKG_MD5SUM:=$(LINUX_KERNEL_MD5SUM)
-LINUX_DIR := $(PKG_BUILD_DIR)
+LINUX_DIR := $(HOST_BUILD_DIR)
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel-defaults.mk
@@ -36,26 +36,26 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
LINUX_HAS_HEADERS_INSTALL:=y
endif
-KMAKE := $(MAKE) -C $(PKG_BUILD_DIR) \
+KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
ARCH=$(LINUX_KARCH) \
KBUILD_HAVE_NLS=no \
CONFIG_SHELL=$(BASH)
-define Build/Prepare/pre/cris
- ln -sf $(PKG_BUILD_DIR)/include/asm-cris/arch-v10 $(PKG_BUILD_DIR)/include/asm-cris/arch
- ln -sf $(PKG_BUILD_DIR)/include/asm-cris/arch-v10 $(PKG_BUILD_DIR)/arch/cris/arch
+define Host/Prepare/pre/cris
+ ln -sf $(HOST_BUILD_DIR)/include/asm-cris/arch-v10 $(HOST_BUILD_DIR)/include/asm-cris/arch
+ ln -sf $(HOST_BUILD_DIR)/include/asm-cris/arch-v10 $(HOST_BUILD_DIR)/arch/cris/arch
endef
-define Build/Prepare/pre/powerpc
- if [ -d $(PKG_BUILD_DIR)/include/asm-ppc ]; then \
- $(CP) $(PKG_BUILD_DIR)/include/asm-ppc/* $(PKG_BUILD_DIR)/include/asm-powerpc/; \
- rm -rf $(PKG_BUILD_DIR)/include/asm-ppc; \
- ln -s $(PKG_BUILD_DIR)/include/asm-powerpc $(PKG_BUILD_DIR)/include/asm-ppc; \
+define Host/Prepare/pre/powerpc
+ if [ -d $(HOST_BUILD_DIR)/include/asm-ppc ]; then \
+ $(CP) $(HOST_BUILD_DIR)/include/asm-ppc/* $(HOST_BUILD_DIR)/include/asm-powerpc/; \
+ rm -rf $(HOST_BUILD_DIR)/include/asm-ppc; \
+ ln -s $(HOST_BUILD_DIR)/include/asm-powerpc $(HOST_BUILD_DIR)/include/asm-ppc; \
fi
endef
ifneq ($(LINUX_HAS_HEADERS_INSTALL),)
- define Build/Prepare/all
+ define Host/Prepare/all
mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr
$(KMAKE) \
CROSS_COMPILE=$(TARGET_CROSS) \
@@ -63,85 +63,85 @@ ifneq ($(LINUX_HAS_HEADERS_INSTALL),)
headers_install
endef
else
- define Build/Prepare/all
+ define Host/Prepare/all
mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include
cp -pLR \
- $(PKG_BUILD_DIR)/include/asm \
- $(PKG_BUILD_DIR)/include/asm-generic \
- $(PKG_BUILD_DIR)/include/asm-$(LINUX_KARCH) \
- $(PKG_BUILD_DIR)/include/linux \
+ $(HOST_BUILD_DIR)/include/asm \
+ $(HOST_BUILD_DIR)/include/asm-generic \
+ $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH) \
+ $(HOST_BUILD_DIR)/include/linux \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/
endef
endif
# XXX: the following is needed to build lzma-loader
-define Build/Prepare/lzma
+define Host/Prepare/lzma
$(CP) \
- $(PKG_BUILD_DIR)/include/asm-mips/asm.h \
- $(PKG_BUILD_DIR)/include/asm-mips/regdef.h \
+ $(HOST_BUILD_DIR)/include/asm-mips/asm.h \
+ $(HOST_BUILD_DIR)/include/asm-mips/regdef.h \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
endef
# XXX: the following are needed to build a cris toolchain
-define Build/Prepare/post/cris
+define Host/Prepare/post/cris
$(CP) \
- $(PKG_BUILD_DIR)/include/linux/user.h \
+ $(HOST_BUILD_DIR)/include/linux/user.h \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/linux/
$(CP) \
- $(PKG_BUILD_DIR)/include/asm-cris/elf.h \
- $(PKG_BUILD_DIR)/include/asm-cris/page.h \
- $(PKG_BUILD_DIR)/include/asm-cris/user.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/elf.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/page.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/user.h \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/arch
$(CP) \
- $(PKG_BUILD_DIR)/include/asm-cris/arch/elf.h \
- $(PKG_BUILD_DIR)/include/asm-cris/arch/page.h \
- $(PKG_BUILD_DIR)/include/asm-cris/arch/ptrace.h \
- $(PKG_BUILD_DIR)/include/asm-cris/arch/user.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/arch/elf.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/arch/page.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/arch/ptrace.h \
+ $(HOST_BUILD_DIR)/include/asm-cris/arch/user.h \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/arch/
$(CP) \
- $(PKG_BUILD_DIR)/include/asm-generic/memory_model.h \
- $(PKG_BUILD_DIR)/include/asm-generic/page.h \
+ $(HOST_BUILD_DIR)/include/asm-generic/memory_model.h \
+ $(HOST_BUILD_DIR)/include/asm-generic/page.h \
$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm-generic/
endef
-define Build/Prepare/post/mips
- $(call Build/Prepare/lzma)
+define Host/Prepare/post/mips
+ $(call Host/Prepare/lzma)
endef
-define Build/Prepare/post/mipsel
- $(call Build/Prepare/lzma)
+define Host/Prepare/post/mipsel
+ $(call Host/Prepare/lzma)
endef
-define Build/Prepare
+define Host/Prepare
$(call Kernel/Prepare/Default)
ln -sf linux-$(LINUX_VERSION) $(BUILD_DIR_TOOLCHAIN)/linux
- $(SED) 's/@expr length/@-expr length/' $(PKG_BUILD_DIR)/Makefile
+ $(SED) 's/@expr length/@-expr length/' $(HOST_BUILD_DIR)/Makefile
yes '' | $(KMAKE) oldconfig
$(KMAKE) include/linux/version.h include/asm
- if [ -d $(PKG_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
+ if [ -d $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
$(CP) \
- $(PKG_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm/. \
- $(PKG_BUILD_DIR)/include/asm-$(LINUX_KARCH)/; \
+ $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm/. \
+ $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH)/; \
fi
- $(call Build/Prepare/pre/$(ARCH))
- $(call Build/Prepare/all)
- $(call Build/Prepare/post/$(ARCH))
+ $(call Host/Prepare/pre/$(ARCH))
+ $(call Host/Prepare/all)
+ $(call Host/Prepare/post/$(ARCH))
endef
-define Build/Configure
+define Host/Configure
endef
-define Build/Compile
+define Host/Compile
endef
-define Build/Install
+define Host/Install
$(CP) $(BUILD_DIR_TOOLCHAIN)/linux-dev/* $(TOOLCHAIN_DIR)/
endef
-define Build/Clean
+define Host/Clean
rm -rf \
- $(PKG_BUILD_DIR) \
+ $(HOST_BUILD_DIR) \
$(BUILD_DIR_TOOLCHAIN)/linux \
$(BUILD_DIR_TOOLCHAIN)/linux-dev
endef