aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/kernel-headers
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
commit62c174067616a911ef77a8cf02a6cc2220e534ec (patch)
tree30ea6c074ef3e3c343c672c2fcc492453ed252e2 /toolchain/kernel-headers
parentd9e0d5705ab187ff024067049f1077f95074a6c6 (diff)
downloadupstream-62c174067616a911ef77a8cf02a6cc2220e534ec.tar.gz
upstream-62c174067616a911ef77a8cf02a6cc2220e534ec.tar.bz2
upstream-62c174067616a911ef77a8cf02a6cc2220e534ec.zip
toolchain: fix the sysroot mess by getting rid of $(TOOLCHAIN_DIR)/usr and moving it back to $(TOOLCHAIN_DIR), this change makes the toolchain relocatable again, which should fix the SDK
SVN-Revision: 22723
Diffstat (limited to 'toolchain/kernel-headers')
-rw-r--r--toolchain/kernel-headers/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index d2d12c71ae..614c405155 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -42,9 +42,9 @@ KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
CONFIG_SHELL=$(BASH)
define Host/Prepare/all
- mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr
+ mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev
$(KMAKE) \
- INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/" \
+ INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/" \
headers_install
if [ -d $(HOST_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
mkdir -p $(HOST_BUILD_DIR)/include/asm-$(LINUX_KARCH); \
@@ -59,16 +59,16 @@ define Host/Prepare/lzma
$(CP) \
$(HOST_BUILD_DIR)/include/asm-mips/asm.h \
$(HOST_BUILD_DIR)/include/asm-mips/regdef.h \
- $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
+ $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
endef
define Host/Prepare/post/cris
$(CP) \
$(HOST_BUILD_DIR)/include/linux/user.h \
- $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/linux/
- ln -snf $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/arch-v10/arch \
- $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/arch
- $(SED) '/#include <asm\/page\.h>/d' $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/user.h
+ $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/linux/
+ ln -snf $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/arch-v10/arch \
+ $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/arch
+ $(SED) '/#include <asm\/page\.h>/d' $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/user.h
endef
define Host/Prepare/post/ubicom32
@@ -77,7 +77,7 @@ define Host/Prepare/post/ubicom32
$(HOST_BUILD_DIR)/arch/ubicom32/include/asm/user.h \
$(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page.h \
$(HOST_BUILD_DIR)/arch/ubicom32/include/asm/page_offset.h \
- $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr/include/asm/
+ $(BUILD_DIR_TOOLCHAIN)/linux-dev/include/asm/
endef
define Host/Prepare/post/mips