aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/kernel-headers
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-10-12 08:41:41 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-10-16 16:10:38 +0100
commit14881b49d8d7e84f67074845d039f43df1a0d663 (patch)
tree5a4c4bad5bec6a1e4b88f42adb18415d01a628fd /toolchain/kernel-headers
parentbc61458b73c04f900c358be8b7ed37c84298472a (diff)
downloadupstream-14881b49d8d7e84f67074845d039f43df1a0d663.tar.gz
upstream-14881b49d8d7e84f67074845d039f43df1a0d663.tar.bz2
upstream-14881b49d8d7e84f67074845d039f43df1a0d663.zip
toolchain/kernel-headers: don't use TARGET_CFLAGS
Kernel utilities (e.g. scripts/kconfig/conf) are being built to run on the host system at this stage, therefore it makes no sense to use the target system CC flags. Use HOSTCFLAGS instead While we're here rename KMAKE macro to HOST_KMAKE to make it even more obvious that we're building for host. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'toolchain/kernel-headers')
-rw-r--r--toolchain/kernel-headers/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index f7842cb9bd..a4120d587d 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -41,14 +41,14 @@ HOST_EXTRACFLAGS=
LINUX_HAS_HEADERS_INSTALL:=y
-KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
+HOST_KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
$(KERNEL_MAKE_FLAGS) \
CC="$(KERNEL_CC)" \
- CFLAGS="$(TARGET_CFLAGS)"
+ HOSTCFLAGS="$(HOST_CFLAGS)"
define Host/Configure/all
mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev
- $(KMAKE) \
+ $(HOST_KMAKE) \
INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/" \
headers_install
endef
@@ -82,7 +82,7 @@ endef
define Host/Configure
env
- yes '' | $(KMAKE) oldconfig
+ yes '' | $(HOST_KMAKE) oldconfig
$(call Host/Configure/all)
$(call Host/Configure/post/$(ARCH))
endef