aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-26 14:58:32 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-26 14:58:32 +0000
commitf797b4293a6cfa1658a4ecd7d77f12885a8faa8d (patch)
tree49dc5da4f4a39ae68597904f99e7591a1c7b5091 /toolchain/glibc
parentd334c1e9568c9f50a5851d868a40fe8a736d4ddc (diff)
downloadupstream-f797b4293a6cfa1658a4ecd7d77f12885a8faa8d.tar.gz
upstream-f797b4293a6cfa1658a4ecd7d77f12885a8faa8d.tar.bz2
upstream-f797b4293a6cfa1658a4ecd7d77f12885a8faa8d.zip
add support for glibc-2.4 (#5213)
SVN-Revision: 16089
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/Config.in3
-rw-r--r--toolchain/glibc/Config.version2
-rw-r--r--toolchain/glibc/Makefile3
3 files changed, 8 insertions, 0 deletions
diff --git a/toolchain/glibc/Config.in b/toolchain/glibc/Config.in
index e1bffdab2b..67ee729755 100644
--- a/toolchain/glibc/Config.in
+++ b/toolchain/glibc/Config.in
@@ -8,6 +8,9 @@ choice
config GLIBC_VERSION_2_3_6
bool "glibc 2.3.6"
+ config GLIBC_VERSION_2_4
+ bool "glibc 2.4"
+
config GLIBC_VERSION_2_6_1
bool "glibc 2.6.1"
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index 1debf0c040..93ea3c3168 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -2,6 +2,7 @@ config GLIBC_VERSION
string
depends on USE_GLIBC
default "2.3.6" if GLIBC_VERSION_2_3_6
+ default "2.4" if GLIBC_VERSION_2_4
default "2.6.1" if GLIBC_VERSION_2_6_1
default "2.7" if GLIBC_VERSION_2_7
default "2.7"
@@ -10,6 +11,7 @@ config GLIBC_PORTS
bool
depends on USE_GLIBC
default y if GLIBC_VERSION_2_3_6 && (arm || armeb || mips || mipsel || mips64 || mips64el)
+ default y if GLIBC_VERSION_2_4 && (arm || armeb || mips || mipsel || mips64 || mips64el)
default y if GLIBC_VERSION_2_6_1 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
default y if GLIBC_VERSION_2_7 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
default n
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index 229f20649e..5d56d4b98a 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -12,6 +12,9 @@ PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
ifeq ($(PKG_VERSION),2.3.6)
PKG_MD5SUM:=bfdce99f82d6dbcb64b7f11c05d6bc96
endif
+ifeq ($(PKG_VERSION),2.4)
+ PKG_MD5SUM:=7e9a88dcd41fbc53801dbe5bdacaf245
+endif
ifeq ($(PKG_VERSION),2.6.1)
PKG_MD5SUM:=11cf6d3fc86dbe0890b8d00372eb6286
endif