aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorIan Cooper <iancooper@hotmail.com>2020-06-15 22:14:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-06-17 23:57:07 +0200
commitb933f9cf0cb254e368027cad6d5799e45b237df5 (patch)
tree26bbaa3322a276dac5d7cf456d51c328baac9a7e /toolchain/glibc
parentba7ddae9a9d0aae9aaf00cfb2438286c2ee21098 (diff)
downloadupstream-b933f9cf0cb254e368027cad6d5799e45b237df5.tar.gz
upstream-b933f9cf0cb254e368027cad6d5799e45b237df5.tar.bz2
upstream-b933f9cf0cb254e368027cad6d5799e45b237df5.zip
toolchain: remove gcc libssp and use libc variant
Removes the standalone implementation of stack smashing protection in gcc's libssp in favour of the native implementation available in glibc and uclibc. Musl libc already uses its native ssp, so this patch does not affect musl-based toolchains. Stack smashing protection configuration options are now uniform across all supported libc variants. This also makes kernel-level stack smashing protection available for x86_64 and i386 builds using non-musl libc. Signed-off-by: Ian Cooper <iancooper@hotmail.com>
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/common.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index db4f0fcc0e..f0b95d3cc7 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -39,7 +39,6 @@ ifeq ($(ARCH),mips64)
endif
endif
-
# -Os miscompiles w. 2.24 gcc5/gcc6
# only -O2 tested by upstream changeset
# "Optimize i386 syscall inlining for GCC 5"
@@ -61,6 +60,8 @@ GLIBC_CONFIGURE:= \
--without-cvs \
--enable-add-ons \
--$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
+ $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
+ $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
--enable-kernel=4.14.0
export libc_cv_ssp=no