aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-25 14:29:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-25 14:29:23 +0000
commit2efb6be426656110b082a6cffcaf804bfef3320c (patch)
tree571262edf482df90a0d955a79ad02134b6b52233 /toolchain/glibc
parent6aba44bfe04d19d80a4853fa188ad821858dac03 (diff)
downloadupstream-2efb6be426656110b082a6cffcaf804bfef3320c.tar.gz
upstream-2efb6be426656110b082a6cffcaf804bfef3320c.tar.bz2
upstream-2efb6be426656110b082a6cffcaf804bfef3320c.zip
toolchain/glibc: remove broken eglibc 2.15 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44976
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/Config.in7
-rw-r--r--toolchain/glibc/Config.version5
-rw-r--r--toolchain/glibc/common.mk9
3 files changed, 1 insertions, 20 deletions
diff --git a/toolchain/glibc/Config.in b/toolchain/glibc/Config.in
index 72d306e7a4..66ff2f4ff5 100644
--- a/toolchain/glibc/Config.in
+++ b/toolchain/glibc/Config.in
@@ -5,11 +5,6 @@ choice
help
Select the version of glibc you wish to use.
- config EGLIBC_USE_VERSION_2_15
- bool "eglibc 2.15"
- select EGLIBC_VERSION_2_15
- depends on BROKEN
-
config EGLIBC_USE_VERSION_2_19
bool "eglibc 2.19"
select EGLIBC_VERSION_2_19
@@ -21,6 +16,6 @@ choice
endchoice
menu "eglibc configuration"
- depends on TOOLCHAINOPTS && USE_GLIBC && (EGLIBC_USE_VERSION_2_15 || EGLIBC_USE_VERSION_2_19)
+ depends on TOOLCHAINOPTS && USE_GLIBC && EGLIBC_USE_VERSION_2_19
source toolchain/glibc/config/Config.in
endmenu
diff --git a/toolchain/glibc/Config.version b/toolchain/glibc/Config.version
index b4b2fcb4d2..0d84df2175 100644
--- a/toolchain/glibc/Config.version
+++ b/toolchain/glibc/Config.version
@@ -2,13 +2,9 @@ if USE_GLIBC
config GLIBC_VERSION
string
- default "2.15" if EGLIBC_VERSION_2_15
default "2.19" if EGLIBC_VERSION_2_19
default "2.21" if GLIBC_VERSION_2_21
-config EGLIBC_VERSION_2_15
- bool
-
config EGLIBC_VERSION_2_19
default y if !TOOLCHAINOPTS
bool
@@ -19,7 +15,6 @@ config GLIBC_VERSION_2_21
config GLIBC_REVISION
string
- default "18909" if EGLIBC_VERSION_2_15
default "25243" if EGLIBC_VERSION_2_19
default "4e42b5b8f8" if GLIBC_VERSION_2_21
default ""
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index e985de61b9..7487ca2782 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -17,12 +17,6 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
GLIBC_PATH:=
-ifneq ($(CONFIG_EGLIBC_VERSION_2_15),)
- GLIBC_PATH:=libc/
- PKG_SOURCE_PROTO:=svn
- PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
- PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_15
-endif
ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
GLIBC_PATH:=libc/
PKG_SOURCE_PROTO:=svn
@@ -105,9 +99,6 @@ define Host/Prepare
ln -snf $(PKG_SOURCE_SUBDIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
ifeq ($(CONFIG_GLIBC_VERSION_2_21),)
$(SED) 's,y,n,' $(HOST_BUILD_DIR)/libc/option-groups.defaults
-ifneq ($(CONFIG_EGLIBC_VERSION_2_15),)
- ln -sf ../ports $(HOST_BUILD_DIR)/libc/
-endif
endif
endef