aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/glibc-ports
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commit7eb15898755be46e94078faffdacd8c9b0ce66cd (patch)
tree89dc171f7b7c646be5a38ca7d7b99e1be24fa61f /toolchain/glibc-ports
parent6ccc1c8e3c9ad0ac95c728573c300264943d8338 (diff)
downloadupstream-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.gz
upstream-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.bz2
upstream-7eb15898755be46e94078faffdacd8c9b0ce66cd.zip
build system refactoring in preparation for allowing packages to do host-build steps
SVN-Revision: 14610
Diffstat (limited to 'toolchain/glibc-ports')
-rw-r--r--toolchain/glibc-ports/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/toolchain/glibc-ports/Makefile b/toolchain/glibc-ports/Makefile
index d9e5d0d7f5..a60b71f431 100644
--- a/toolchain/glibc-ports/Makefile
+++ b/toolchain/glibc-ports/Makefile
@@ -34,23 +34,23 @@ include $(INCLUDE_DIR)/host-build.mk
STAMP_BUILT:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_built
STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.glibc-ports_installed
-define Build/Prepare
-$(call Build/Prepare/Default)
+define Host/Prepare
+$(call Host/Prepare/Default)
ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endef
-define Build/Configure
+define Host/Configure
endef
-define Build/Compile
+define Host/Compile
endef
-define Build/Install
+define Host/Install
endef
-define Build/Clean
+define Host/Clean
rm -rf \
- $(PKG_BUILD_DIR) \
+ $(HOST_BUILD_DIR) \
$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
endef