aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-05-19 08:20:33 +0300
committerFelix Fietkau <nbd@nbd.name>2016-05-19 19:29:44 +0200
commitd354bfde174514973309e788e11c286f1667c2f5 (patch)
treec71bdb107387fb9c9aedce9b93f8cabbf5ab2378 /toolchain/gdb
parent8d105653b13eb5f56764c8e02f307f4d28a6a3a7 (diff)
downloadupstream-d354bfde174514973309e788e11c286f1667c2f5.tar.gz
upstream-d354bfde174514973309e788e11c286f1667c2f5.tar.bz2
upstream-d354bfde174514973309e788e11c286f1667c2f5.zip
toolchain: Bump ARC tools to arc-2016.03
This change switches ARC tools to the most recent arc-2016.03 version. ARC GNU tools of version arc-2016.03 bring some quite significant changes like: * Binutils v2.26+ (upstream commit id 202ac19 with additional ARC * patches) * GCC v4.8.5 * GDB 7.10 More about changes, improvements and fixes could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2016.03 Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile6
-rw-r--r--toolchain/gdb/patches/arc-2016.03/100-no_extern_inline.patch (renamed from toolchain/gdb/patches/arc-2015.06-gdb/100-no_extern_inline.patch)4
-rw-r--r--toolchain/gdb/patches/arc-2016.03/110-no_testsuite.patch (renamed from toolchain/gdb/patches/arc-2015.06-gdb/110-no_testsuite.patch)4
-rw-r--r--toolchain/gdb/patches/arc-2016.03/120-fix-compile-flag-mismatch.patch (renamed from toolchain/gdb/patches/arc-2015.06-gdb/120-fix-compile-flag-mismatch.patch)2
-rw-r--r--toolchain/gdb/patches/arc-2016.03/200-arc-fix-target-mask.patch13
5 files changed, 21 insertions, 8 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 0e1b0a27bc..97d88d65a6 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
ifeq ($(CONFIG_arc),y)
-PKG_VERSION:=arc-2015.06-gdb
+PKG_VERSION:=arc-2016.03-gdb
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2015.06-gdb/
-PKG_MD5SUM:=d318829bfd2ed62714817f0d25706825
+PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03-gdb
+PKG_MD5SUM:=775caaf6385c16f20b6f53c0a2b95f79
GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
else
PKG_VERSION:=7.11
diff --git a/toolchain/gdb/patches/arc-2015.06-gdb/100-no_extern_inline.patch b/toolchain/gdb/patches/arc-2016.03/100-no_extern_inline.patch
index bbae1d774d..8c18c6e2e7 100644
--- a/toolchain/gdb/patches/arc-2015.06-gdb/100-no_extern_inline.patch
+++ b/toolchain/gdb/patches/arc-2016.03/100-no_extern_inline.patch
@@ -21,11 +21,11 @@
+#endif /* DEFINE_NON_INLINE_P */
--- a/sim/common/sim-arange.h
+++ b/sim/common/sim-arange.h
-@@ -62,7 +62,7 @@ extern void sim_addr_range_delete (ADDR_
+@@ -73,7 +73,7 @@ extern void sim_addr_range_delete (ADDR_
/* Return non-zero if ADDR is in range AR, traversing the entire tree.
If no range is specified, that is defined to mean "everything". */
--extern INLINE int
+-SIM_ARANGE_INLINE int
+extern int
sim_addr_range_hit_p (ADDR_RANGE * /*ar*/, address_word /*addr*/);
#define ADDR_RANGE_HIT_P(ar, addr) \
diff --git a/toolchain/gdb/patches/arc-2015.06-gdb/110-no_testsuite.patch b/toolchain/gdb/patches/arc-2016.03/110-no_testsuite.patch
index 5c5d15c5b8..1b284ea767 100644
--- a/toolchain/gdb/patches/arc-2015.06-gdb/110-no_testsuite.patch
+++ b/toolchain/gdb/patches/arc-2016.03/110-no_testsuite.patch
@@ -1,6 +1,6 @@
--- a/gdb/configure
+++ b/gdb/configure
-@@ -855,8 +855,7 @@ MAKEINFOFLAGS
+@@ -870,8 +870,7 @@ MAKEINFOFLAGS
YACC
YFLAGS
XMKMF'
@@ -10,7 +10,7 @@
multi-ice
gdbserver'
-@@ -5168,7 +5167,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+@@ -5610,7 +5610,7 @@ $as_echo "$with_auto_load_safe_path" >&6
diff --git a/toolchain/gdb/patches/arc-2015.06-gdb/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/arc-2016.03/120-fix-compile-flag-mismatch.patch
index ce34c95b19..c8b41f264a 100644
--- a/toolchain/gdb/patches/arc-2015.06-gdb/120-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/arc-2016.03/120-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@
--- a/gdb/gdbserver/configure
+++ b/gdb/gdbserver/configure
-@@ -2183,7 +2183,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+@@ -2468,7 +2468,7 @@ $as_echo "$as_me: error: \`$ac_var' was
ac_cache_corrupted=: ;;
,);;
*)
diff --git a/toolchain/gdb/patches/arc-2016.03/200-arc-fix-target-mask.patch b/toolchain/gdb/patches/arc-2016.03/200-arc-fix-target-mask.patch
new file mode 100644
index 0000000000..7e51d588ae
--- /dev/null
+++ b/toolchain/gdb/patches/arc-2016.03/200-arc-fix-target-mask.patch
@@ -0,0 +1,13 @@
+diff --git a/bfd/config.bfd b/bfd/config.bfd
+index 5145d4a..a9c9c99 100644
+--- a/bfd/config.bfd
++++ b/bfd/config.bfd
+@@ -275,7 +275,7 @@ case "${targ}" in
+ targ_defvec=am33_elf32_linux_vec
+ ;;
+
+- arc*-*-elf* | arc*-*-linux-uclibc*)
++ arc*-*-elf* | arc*-*-linux-*)
+ targ_defvec=arc_elf32_le_vec
+ targ_selvecs=arc_elf32_be_vec
+ ;;