aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-09-06 14:43:56 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-09-07 17:21:24 +0200
commitc24d02d15421bfe67f0fedee3a30259567478e5a (patch)
treed78fe0a1eda4e1cbb9d013cd9a210e8145ac92d0 /toolchain/gdb
parent77024a9d953d394b02226367357b0570c52b9119 (diff)
downloadupstream-c24d02d15421bfe67f0fedee3a30259567478e5a.tar.gz
upstream-c24d02d15421bfe67f0fedee3a30259567478e5a.tar.bz2
upstream-c24d02d15421bfe67f0fedee3a30259567478e5a.zip
toolchain/gdb: bump to 8.2
*** Changes in GDB 8.2 Support for the following target has been added: RiscV ELF (riscv*-*-elf) Support for following targets and native configurations has been removed: m88k running OpenBSD (m88*-*-openbsd*) SH-5/SH64 ELF (sh64-*-elf*) SH-5/SH64 (sh*) SH-5/SH64 running GNU/Linux (sh*-*-linux*) SH-5/SH64 running OpenBSD (sh*-*-openbsd*) Various Python API enhancements Aarch64/Linux enhancements: SVE support. Hardware watchpoints improvements for entities stored at unaligned addresses. New "c" response to disable the pager for the rest of the current command. C expressions can now use _Alignof, and C++ expressions can now use alignof. Improved flexibility for loading symbol files. The 'info proc' command nows works on running processes on FreeBSD systems as well as core files created on FreeBSD systems. A new --enable-codesign=CERT configure option to automatically codesign GDB after build (useful on MacOS X). Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile4
-rw-r--r--toolchain/gdb/patches/110-no_testsuite.patch4
-rw-r--r--toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 69029332e1..49816618ff 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -17,11 +17,11 @@ PKG_HASH:=7e3c2a763bf500a40c5c4591a7e22c591dafc1f214b1d514895c1096e85c883a
GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
PATCH_DIR:=./patches-arc
else
-PKG_VERSION:=8.1.1
+PKG_VERSION:=8.2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=97dcc3169bd430270fc29adb65145846a58c1b55cdbb73382a4a89307bdad03c
+PKG_HASH:=c3a441a29c7c89720b734e5a9c6289c0a06be7e0c76ef538f7bbcef389347c39
GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
endif
diff --git a/toolchain/gdb/patches/110-no_testsuite.patch b/toolchain/gdb/patches/110-no_testsuite.patch
index f87cdd2b76..bcb10e69b4 100644
--- a/toolchain/gdb/patches/110-no_testsuite.patch
+++ b/toolchain/gdb/patches/110-no_testsuite.patch
@@ -1,6 +1,6 @@
--- a/gdb/configure
+++ b/gdb/configure
-@@ -881,8 +881,7 @@ MAKEINFOFLAGS
+@@ -915,8 +915,7 @@ MAKEINFOFLAGS
YACC
YFLAGS
XMKMF'
@@ -10,7 +10,7 @@
multi-ice
gdbserver'
-@@ -6488,7 +6487,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+@@ -6577,7 +6576,7 @@ $as_echo "$with_auto_load_safe_path" >&6
diff --git a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
index 7bb46aafcc..d971e28d88 100644
--- a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@
--- a/gdb/gdbserver/configure
+++ b/gdb/gdbserver/configure
-@@ -2470,7 +2470,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+@@ -2508,7 +2508,7 @@ $as_echo "$as_me: error: \`$ac_var' was
ac_cache_corrupted=: ;;
,);;
*)