aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2017-09-04 20:20:12 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2018-07-03 14:19:10 +0100
commit900d86766b2a2122ea435d98aa50dc72d5dadf93 (patch)
tree6035bd951af01064601c8c106a32b02fe4734c83 /toolchain/gdb
parentfbf475403b911f46e91b57fb7a6cf3c65276464c (diff)
downloadupstream-900d86766b2a2122ea435d98aa50dc72d5dadf93.tar.gz
upstream-900d86766b2a2122ea435d98aa50dc72d5dadf93.tar.bz2
upstream-900d86766b2a2122ea435d98aa50dc72d5dadf93.zip
toolchain: gdb: enable TUI
The GDB Text User Interface (TUI) is a terminal interface which uses the curses library to show the source file, the assembly output, the program registers and GDB commands in separate text windows. In other words it's a friendlier interface for idiots like me! Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 5c80eef9aa..fda3401961 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -41,7 +41,7 @@ HOST_CONFIGURE_ARGS = \
--target=$(REAL_GNU_TARGET_NAME) \
--disable-werror \
--without-uiout \
- --disable-tui --disable-gdbtk --without-x \
+ --enable-tui --disable-gdbtk --without-x \
--without-included-gettext \
--enable-threads \
--with-expat \