aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-10 12:03:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-10 12:03:59 +0000
commit8b5d644bb36846660e1fa20d38361fec12a14b28 (patch)
tree3862ad9cadac2989690765d921a16b875147180a /toolchain/gdb
parent759b1c11872d5df4bd198aaff2a5cf7e68a85314 (diff)
downloadupstream-8b5d644bb36846660e1fa20d38361fec12a14b28.tar.gz
upstream-8b5d644bb36846660e1fa20d38361fec12a14b28.tar.bz2
upstream-8b5d644bb36846660e1fa20d38361fec12a14b28.zip
toolchain: add support of ARC architecture
This includes binutils, gcc, gdb and uClibc-ng. Latest release of ARC gcc (as of today it is "arc-2015.06") is based on upstream gcc 4.8.4. Sources are available on GitHub, see: https://github.com/foss-for-synopsys-dwc-arc-processors/gcc Latest release of ARC binutils (as of today it is "arc-2015.06") is based on upstream binutils 2.23. Sources are available on GitHub, see: https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/releases/tag/arc-2015.06 Latest release of ARC GDB (as of today this is "arc-2015.06-gdb") is based on upstream gdb 7.9.1. Sources are available on GitHub, see: https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/releases/tag/arc-2015.06-gdb Note that for binutils and gdb that come from unified git repository (which is the case for upstream binutils/gdb today) we need to disable building of gdb in binutils and binutils in gdb hence in binutils: ------>8------ --disable-sim --disable-gdb ------>8------ and in gdb: ------>8------ --disable-binutils --disable-ld --disable-gas ------>8------ Also in gdb we disable sim because if the following breakage while building with it: ------------>8------------ /usr/bin/env bash ./../common/genmloop.sh -shell /usr/bin/env bash \ -mono -fast -pbb -switch sem5-switch.c \ -cpu a5f -infile ./mloop5.in \ -outfile-suffix 5 unknown option: bash Makefile:699: recipe for target 'stamp-5mloop' failed make[7]: *** [stamp-5mloop] Error 1 ------------>8------------ Cc: Felix Fietkau <nbd@openwrt.org> Cc: John Crispin <blogic@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> SVN-Revision: 47438
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index f3bca77306..d3fe164e63 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -7,11 +7,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
+
+ifeq ($(CONFIG_arc),y)
+PKG_VERSION:=arc-2015.06-gdb
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2015.06-gdb/
+PKG_MD5SUM:=d318829bfd2ed62714817f0d25706825
+GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
+else
PKG_VERSION:=7.10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
PKG_MD5SUM:=2a35bac41fa8e10bf04f3a0dd7f7f363
+GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
+endif
+
+HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
HOST_BUILD_PARALLEL:=1
@@ -30,7 +43,11 @@ HOST_CONFIGURE_ARGS = \
--disable-tui --disable-gdbtk --without-x \
--without-included-gettext \
--enable-threads \
- --with-expat
+ --with-expat \
+ --disable-binutils \
+ --disable-ld \
+ --disable-gas \
+ --disable-sim
define Host/Install
mkdir -p $(TOOLCHAIN_DIR)/bin