aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2018-08-01 13:39:03 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2018-08-01 16:12:53 +0200
commit3df400c87ed9852d3641340b96849d9117355337 (patch)
treed08665f01ec351188466fe8c0e444ab4b3c48006 /toolchain/gdb
parentf63f20fb93c7e67775cb01d97fc88b5b29452b81 (diff)
downloadupstream-3df400c87ed9852d3641340b96849d9117355337.tar.gz
upstream-3df400c87ed9852d3641340b96849d9117355337.tar.bz2
upstream-3df400c87ed9852d3641340b96849d9117355337.zip
toolchain/gdb: bump to 8.1.1
GDB 8.1.1 brings the following fixes and enhancements over GDB 8.1: * PR gdb/22824 (misleading description of new rbreak Python function in GDB 8.1 NEWS file) * PR gdb/22849 (ctrl-c doesn't work in extended-remote) * PR gdb/22907 ([Regression] gdbserver doesn't work with filename-only binaries) * PR gdb/23028 (inconsistent disassemble of vcvtpd2dq) * PR gdb/23053 (Fix -D_GLIBCXX_DEBUG gdb-add-index regression) * PR gdb/23127 ([AArch64] GDB cannot be used for debugging software that uses high Virtual Addresses) * PR server/23158 (gdbserver no longer functional on Windows) * PR breakpoints/23210 ([8.1/8.2 Regression] Bogus Breakpoint address adjusted from 0xf7fe7dd3 to 0xfffffffff7fe7dd3) GDB 8.1 includes the following changes and enhancements: * Breakpoints on C++ functions are now set on all scopes by default ("wild" matching); * Support for inserting breakpoints on functions marked with C++ ABI tags; * Target floating-point arithmetic emulation during expression evaluation (requires MPFR 3.1 or later); * Various Python Scripting enhancements; * Improved Rust support; in particular, Trait objects can now be inspected when debugging Rust code; * GDB no longer makes assumptions about the type of symbols without debugging information to avoid producing erroneous and often confusing results; * The 'enable' and 'disable' commands now accept a range of breakpoint locations; * New 'starti' command to start the program at the first instruction; * New 'rbreak' command to insert a number of breakpoints via a regular expression pattern (requires Python); * The 'ptype' command now supports printing the offset and size of the fields in a struct; * The 'gcore' command now supports dumping all the memory mappings ('-a' command-line option); * New shortcuts for TUI Single-Key mode: 'i' for stepi, and 'o' for nexti; * GDBserver enhancements: ** Support for transmitting environment variables to GDBserver; ** Support for starting inferior processes with a specified initial working directory; ** On Unix systems, support for globbing expansion and variable substitution of inferior command-line arguments; * Various completion enhancements; * The command used to compile and inject code with the 'compile' command is now configurable; * New '--readnever' command-line option to speed the GDB startup when debugging information is not needed; * Support for the following new native configurations: ** FreeBSD/aarch64 (aarch64*-*-freebsd*); ** FreeBSD/arm (arm*-*-freebsd*); * Support for the following new targets: ** FreeBSD/aarch64 (aarch64*-*-freebsd*); ** FreeBSD/arm (arm*-*-freebsd*); ** OpenRISC ELF (or1k*-*-elf) * Removed support for the following targets and native configurations: ** Solaris2/x86 (i?86-*-solaris2.[0-9]); ** Solaris2/sparc (sparc*-*-solaris2.[0-9]); Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile4
-rw-r--r--toolchain/gdb/patches/110-no_testsuite.patch4
-rw-r--r--toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index fda3401961..69029332e1 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -17,11 +17,11 @@ PKG_HASH:=7e3c2a763bf500a40c5c4591a7e22c591dafc1f214b1d514895c1096e85c883a
GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
PATCH_DIR:=./patches-arc
else
-PKG_VERSION:=8.0.1
+PKG_VERSION:=8.1.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=3dbd5f93e36ba2815ad0efab030dcd0c7b211d7b353a40a53f4c02d7d56295e3
+PKG_HASH:=97dcc3169bd430270fc29adb65145846a58c1b55cdbb73382a4a89307bdad03c
GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
endif
diff --git a/toolchain/gdb/patches/110-no_testsuite.patch b/toolchain/gdb/patches/110-no_testsuite.patch
index e86ba6d0cd..f87cdd2b76 100644
--- a/toolchain/gdb/patches/110-no_testsuite.patch
+++ b/toolchain/gdb/patches/110-no_testsuite.patch
@@ -1,6 +1,6 @@
--- a/gdb/configure
+++ b/gdb/configure
-@@ -869,8 +869,7 @@ MAKEINFOFLAGS
+@@ -881,8 +881,7 @@ MAKEINFOFLAGS
YACC
YFLAGS
XMKMF'
@@ -10,7 +10,7 @@
multi-ice
gdbserver'
-@@ -6473,7 +6472,7 @@ $as_echo "$with_auto_load_safe_path" >&6
+@@ -6488,7 +6487,7 @@ $as_echo "$with_auto_load_safe_path" >&6
diff --git a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
index 9ce91a024b..7bb46aafcc 100644
--- a/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/120-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@
--- a/gdb/gdbserver/configure
+++ b/gdb/gdbserver/configure
-@@ -2469,7 +2469,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+@@ -2470,7 +2470,7 @@ $as_echo "$as_me: error: \`$ac_var' was
ac_cache_corrupted=: ;;
,);;
*)