aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-09-11 13:16:13 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-09-11 13:16:13 +0000
commit2dad4ed3579cfc52fc819da7b6d9823385153b76 (patch)
treeba3779f3b365edc93e4f8ea526fa67537baca1d7 /toolchain/gdb
parent4434bc361d13cae18527414d74b66892e48b33be (diff)
downloadupstream-2dad4ed3579cfc52fc819da7b6d9823385153b76.tar.gz
upstream-2dad4ed3579cfc52fc819da7b6d9823385153b76.tar.bz2
upstream-2dad4ed3579cfc52fc819da7b6d9823385153b76.zip
upgrade to 7.6-2013.05
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 37943
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile10
-rw-r--r--toolchain/gdb/patches/100-ppc_compile_fix.patch2
-rw-r--r--toolchain/gdb/patches/200-linux_musl.patch22
-rw-r--r--toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch14
4 files changed, 13 insertions, 35 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 6d4c16d926..627baff528 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
-PKG_REV:=7.5-2012.12-1
-PKG_VERSION_MAJOR:=7.5
+PKG_REV:=7.6-2013.05
+PKG_VERSION_MAJOR:=7.6
PKG_VERSION:=linaro-$(PKG_REV)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=016cf2c5ed06adf7c601e3301a14e370
-PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+PKG_MD5SUM:=816290b91cff03912320089d353e8a12
+PKG_SOURCE_URL:=https://releases.linaro.org/13.05/components/toolchain/gdb-linaro/
HOST_BUILD_PARALLEL:=1
diff --git a/toolchain/gdb/patches/100-ppc_compile_fix.patch b/toolchain/gdb/patches/100-ppc_compile_fix.patch
index 4c5cb4efd9..9ecaaed8e4 100644
--- a/toolchain/gdb/patches/100-ppc_compile_fix.patch
+++ b/toolchain/gdb/patches/100-ppc_compile_fix.patch
@@ -1,6 +1,6 @@
--- a/sim/ppc/Makefile.in
+++ b/sim/ppc/Makefile.in
-@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+@@ -550,7 +550,7 @@ PACKAGE_SRC = @sim_pk_src@
PACKAGE_OBJ = @sim_pk_obj@
diff --git a/toolchain/gdb/patches/200-linux_musl.patch b/toolchain/gdb/patches/200-linux_musl.patch
deleted file mode 100644
index 738bc8b55f..0000000000
--- a/toolchain/gdb/patches/200-linux_musl.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -urN gdb-linaro-7.5-2012.09/config.sub gdb-linaro-7.5-2012.09.new/config.sub
---- gdb-linaro-7.5-2012.09/config.sub 2012-09-13 16:01:23.000000000 +0200
-+++ gdb-linaro-7.5-2012.09.new/config.sub 2012-11-21 18:19:43.516916352 +0100
-@@ -126,7 +126,8 @@
- linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
- knetbsd*-gnu* | netbsd*-gnu* | \
- kopensolaris*-gnu* | \
-- storm-chaos* | os2-emx* | rtmk-nova*)
-+ storm-chaos* | os2-emx* | rtmk-nova* | \
-+ linux-musl*)
- os=-$maybe_os
- basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
- ;;
-@@ -1360,7 +1361,7 @@
- | -chorusos* | -chorusrdb* | -cegcc* \
- | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
- | -mingw32* | -linux-gnu* | -linux-android* \
-- | -linux-newlib* | -linux-uclibc* \
-+ | -linux-newlib* | -linux-uclibc* | -linux-musl* \
- | -uxpv* | -beos* | -mpeix* | -udk* \
- | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
- | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
diff --git a/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
index 517cf12b00..127bee46d8 100644
--- a/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
@@ -1,6 +1,6 @@
---- a/gdb/configure 2012-09-13 16:01:22.000000000 +0200
-+++ b/gdb/configure 2012-10-12 17:48:06.863908023 +0200
-@@ -828,8 +828,7 @@
+--- a/gdb/configure
++++ b/gdb/configure
+@@ -834,8 +834,7 @@ MAKEINFOFLAGS
YACC
YFLAGS
XMKMF'
@@ -10,7 +10,7 @@
multi-ice
gdbserver'
-@@ -5023,7 +5022,7 @@
+@@ -5033,7 +5032,7 @@ $as_echo "$with_auto_load_safe_path" >&6
@@ -19,9 +19,9 @@
# Check whether to support alternative target configurations
---- a/gdb/gdbserver/configure 2012-09-13 16:01:22.000000000 +0200
-+++ b/gdb/gdbserver/configure 2012-10-12 17:49:29.775910147 +0200
-@@ -2173,7 +2173,7 @@
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -2181,7 +2181,7 @@ $as_echo "$as_me: error: \`$ac_var' was
ac_cache_corrupted=: ;;
,);;
*)