aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-10 19:42:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-10 19:42:12 +0000
commit05ae45ac6fa2b8a090b2854ba72ef490bf2584ff (patch)
tree9e21bdd0a732814ad1ce3e4c07b2dae67010f3e3 /toolchain/gdb
parentae706ea6b6de775de99019a61fd335e0aba5122c (diff)
downloadupstream-05ae45ac6fa2b8a090b2854ba72ef490bf2584ff.tar.gz
upstream-05ae45ac6fa2b8a090b2854ba72ef490bf2584ff.tar.bz2
upstream-05ae45ac6fa2b8a090b2854ba72ef490bf2584ff.zip
toolchain/gdb: use expat library to be able to parse target machine definitions
Fixes gdbserver debugging with at least mvebu, possibly others Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46298
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/Makefile30
1 files changed, 14 insertions, 16 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index d3f1e8c0aa..fa5179a5dc 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -17,22 +17,20 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- gdb_cv_func_sigsetjmp=yes \
- CFLAGS="-O2" \
- $(HOST_BUILD_DIR)/configure \
- --prefix=$(TOOLCHAIN_DIR) \
- --build=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
- --disable-werror \
- --without-uiout \
- --disable-tui --disable-gdbtk --without-x \
- --without-included-gettext \
- --enable-threads \
- );
-endef
+HOST_CONFIGURE_VARS += \
+ gdb_cv_func_sigsetjmp=yes
+
+HOST_CONFIGURE_ARGS = \
+ --prefix=$(TOOLCHAIN_DIR) \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --disable-werror \
+ --without-uiout \
+ --disable-tui --disable-gdbtk --without-x \
+ --without-included-gettext \
+ --enable-threads \
+ --with-expat
define Host/Install
mkdir -p $(TOOLCHAIN_DIR)/bin