aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-17 12:38:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-17 12:38:32 +0000
commit79452344feffbe2944c196b602790ed8451ea44c (patch)
tree1337a7e3c24cdf12328bb9087149b5ec5144c196 /toolchain/gdb/Makefile
parent331735a357a73c7b8adc205241ac3cc6543d985e (diff)
downloadupstream-79452344feffbe2944c196b602790ed8451ea44c.tar.gz
upstream-79452344feffbe2944c196b602790ed8451ea44c.tar.bz2
upstream-79452344feffbe2944c196b602790ed8451ea44c.zip
gdb: use separate patches for upstream and ARC gdb
With bump of upstream GDB from 7.9 to 7.10 at least 100-no_extern_inline.patch became incompatible with ARC gdb (which is still based on upstream 7.9 branch). So until ARC support is not completely upstreamed (which we expect to happen in coming months) we'll need to have separate patches for ARC gdb. This time clean build-tested for Netgear WNDRMAC & AXS101. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: John Crispin <blogic@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 47491
Diffstat (limited to 'toolchain/gdb/Makefile')
-rw-r--r--toolchain/gdb/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 38ffb0b77f..f74b64ed94 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -24,6 +24,8 @@ PKG_MD5SUM:=2a35bac41fa8e10bf04f3a0dd7f7f363
GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
endif
+PATCH_DIR:=./patches/$(PKG_VERSION)
+
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
HOST_BUILD_PARALLEL:=1