aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-14 11:47:36 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-15 14:17:26 +0200
commit0aa64508403d3f32c531d769cb78826597305059 (patch)
treea104d756c4ccd46aa2b881a13ce3e1a7d7800e23 /toolchain/gdb/Makefile
parent0f4a337b31f2d3bc6baf995fad0a5b05b96adeb2 (diff)
downloadupstream-0aa64508403d3f32c531d769cb78826597305059.tar.gz
upstream-0aa64508403d3f32c531d769cb78826597305059.tar.bz2
upstream-0aa64508403d3f32c531d769cb78826597305059.zip
toolchain/gdb: reorganize patch layout
Use ./patches and ./patches-arc instead of version dependent patches. We should have only one main supported version (along with the special case for arc). Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gdb/Makefile')
-rw-r--r--toolchain/gdb/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/toolchain/gdb/Makefile b/toolchain/gdb/Makefile
index 97d88d65a6..8d41ee9781 100644
--- a/toolchain/gdb/Makefile
+++ b/toolchain/gdb/Makefile
@@ -15,6 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03-gdb
PKG_MD5SUM:=775caaf6385c16f20b6f53c0a2b95f79
GDB_DIR:=binutils-$(PKG_NAME)-$(PKG_VERSION)
+PATCH_DIR:=./patches-arc
else
PKG_VERSION:=7.11
@@ -24,8 +25,6 @@ PKG_MD5SUM:=b5c784685e1cde65ba135feea86b6d75
GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
endif
-PATCH_DIR:=./patches/$(PKG_VERSION)
-
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
HOST_BUILD_PARALLEL:=1