aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-01 08:29:06 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-01 15:18:38 +0100
commitf204e0fc4619c7c64d0d99b87b0ddd802338d78a (patch)
tree53e934d8cb9f9d3c668852120de62ee815812530 /toolchain/gcc
parentd86802acd8ebe0aaf855dc75ad6276856032bfef (diff)
downloadupstream-f204e0fc4619c7c64d0d99b87b0ddd802338d78a.tar.gz
upstream-f204e0fc4619c7c64d0d99b87b0ddd802338d78a.tar.bz2
upstream-f204e0fc4619c7c64d0d99b87b0ddd802338d78a.zip
toolchain/gcc: reduce source directory size by about 420 MB
Remove gcc testsuite, ada and libjava (if not selected) Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index fce8a5165c..c6e01b5758 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -71,6 +71,12 @@ HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.gcc_$(GCC_VARIANT)_installed
SEP:=,
TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
+TAR_OPTIONS += --exclude='gcc/testsuite/*' --exclude=gcc/ada/*.ad*
+
+ifndef CONFIG_INSTALL_LIBGCJ
+ TAR_OPTIONS += --exclude=libjava
+endif
+
export libgcc_cv_fixed_point=no
ifdef CONFIG_USE_UCLIBC
export glibcxx_cv_c99_math_tr1=no