aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-19 10:38:45 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-11-19 14:59:03 +0100
commite5c18dad14956ef41488fc7016ef0aa57e7347c7 (patch)
treee5ae1c45ecfaa8580ab64b4ac5426b72ac7b1c66 /toolchain/gcc
parent7533087565005ecb41954790d4991cb7c32bb066 (diff)
downloadupstream-e5c18dad14956ef41488fc7016ef0aa57e7347c7.tar.gz
upstream-e5c18dad14956ef41488fc7016ef0aa57e7347c7.tar.bz2
upstream-e5c18dad14956ef41488fc7016ef0aa57e7347c7.zip
toolchain/gcc: bump to 7.5.0
This updates the GCC to the next minor release which fixes +213 bugs. Tested on ARMv6, ARMv7, MIPS R2, x86 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/7.5.0/001-revert_register_mode_search.patch (renamed from toolchain/gcc/patches/7.4.0/001-revert_register_mode_search.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/7.4.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/010-documentation.patch (renamed from toolchain/gcc/patches/7.4.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/110-Fix-MIPS-PR-84790.patch (renamed from toolchain/gcc/patches/7.4.0/110-Fix-MIPS-PR-84790.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/7.4.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/7.4.0/300-mips_Os_cpu_rtx_cost_model.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/800-arm_v5te_no_ldrd_strd.patch (renamed from toolchain/gcc/patches/7.4.0/800-arm_v5te_no_ldrd_strd.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/7.4.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/7.4.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/7.4.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/7.4.0/850-use_shared_libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/7.4.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/7.4.0/870-ppc_no_crtsavres.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/7.4.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/7.4.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/7.4.0/910-mbsd_multi.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/7.4.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/7.4.0/930-fix-mips-noexecstack.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/931-libffi-fix-MIPS-softfloat-build-issue.patch (renamed from toolchain/gcc/patches/7.4.0/931-libffi-fix-MIPS-softfloat-build-issue.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/940-no-clobber-stamp-bits.patch (renamed from toolchain/gcc/patches/7.4.0/940-no-clobber-stamp-bits.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/950-cpp_file_path_translation.patch (renamed from toolchain/gcc/patches/7.4.0/950-cpp_file_path_translation.patch)0
-rw-r--r--toolchain/gcc/patches/7.5.0/960-gotools-fix-compilation-when-making-cross-compiler.patch (renamed from toolchain/gcc/patches/7.4.0/960-gotools-fix-compilation-when-making-cross-compiler.patch)0
24 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 687857bd1f..7819e9d039 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -13,7 +13,7 @@ config GCC_VERSION_9
config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5
- default "7.4.0" if GCC_VERSION_7
+ default "7.5.0" if GCC_VERSION_7
default "9.2.0" if GCC_VERSION_9
default "8.3.0"
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 883d2a0b4a..8ce8d84a5f 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -32,8 +32,8 @@ ifeq ($(PKG_VERSION),5.5.0)
PKG_HASH:=530cea139d82fe542b358961130c69cfde8b3d14556370b65823d2f91f0ced87
endif
-ifeq ($(PKG_VERSION),7.4.0)
- PKG_HASH:=eddde28d04f334aec1604456e536416549e9b1aa137fc69204e65eb0c009fe51
+ifeq ($(PKG_VERSION),7.5.0)
+ PKG_HASH:=b81946e7f01f90528a1f7352ab08cc602b9ccc05d4e44da4bd501c5a189ee661
endif
ifeq ($(PKG_VERSION),8.3.0)
diff --git a/toolchain/gcc/patches/7.4.0/001-revert_register_mode_search.patch b/toolchain/gcc/patches/7.5.0/001-revert_register_mode_search.patch
index 63e3fee003..63e3fee003 100644
--- a/toolchain/gcc/patches/7.4.0/001-revert_register_mode_search.patch
+++ b/toolchain/gcc/patches/7.5.0/001-revert_register_mode_search.patch
diff --git a/toolchain/gcc/patches/7.4.0/002-case_insensitive.patch b/toolchain/gcc/patches/7.5.0/002-case_insensitive.patch
index 3442076d7d..3442076d7d 100644
--- a/toolchain/gcc/patches/7.4.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/7.5.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/7.4.0/010-documentation.patch b/toolchain/gcc/patches/7.5.0/010-documentation.patch
index 0106814f41..0106814f41 100644
--- a/toolchain/gcc/patches/7.4.0/010-documentation.patch
+++ b/toolchain/gcc/patches/7.5.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/7.4.0/110-Fix-MIPS-PR-84790.patch b/toolchain/gcc/patches/7.5.0/110-Fix-MIPS-PR-84790.patch
index 643c5e68a8..643c5e68a8 100644
--- a/toolchain/gcc/patches/7.4.0/110-Fix-MIPS-PR-84790.patch
+++ b/toolchain/gcc/patches/7.5.0/110-Fix-MIPS-PR-84790.patch
diff --git a/toolchain/gcc/patches/7.4.0/230-musl_libssp.patch b/toolchain/gcc/patches/7.5.0/230-musl_libssp.patch
index eebee9175c..eebee9175c 100644
--- a/toolchain/gcc/patches/7.4.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/7.5.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/7.4.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/7.5.0/300-mips_Os_cpu_rtx_cost_model.patch
index 2d0ae46138..2d0ae46138 100644
--- a/toolchain/gcc/patches/7.4.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/7.5.0/300-mips_Os_cpu_rtx_cost_model.patch
diff --git a/toolchain/gcc/patches/7.4.0/800-arm_v5te_no_ldrd_strd.patch b/toolchain/gcc/patches/7.5.0/800-arm_v5te_no_ldrd_strd.patch
index 76200a1661..76200a1661 100644
--- a/toolchain/gcc/patches/7.4.0/800-arm_v5te_no_ldrd_strd.patch
+++ b/toolchain/gcc/patches/7.5.0/800-arm_v5te_no_ldrd_strd.patch
diff --git a/toolchain/gcc/patches/7.4.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/7.5.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/7.4.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/7.5.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/7.4.0/820-libgcc_pic.patch b/toolchain/gcc/patches/7.5.0/820-libgcc_pic.patch
index 0cc1e07e2b..0cc1e07e2b 100644
--- a/toolchain/gcc/patches/7.4.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/7.5.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/7.4.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/7.5.0/840-armv4_pass_fix-v4bx_to_ld.patch
index b9c9b161ad..b9c9b161ad 100644
--- a/toolchain/gcc/patches/7.4.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/7.5.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/7.4.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/7.5.0/850-use_shared_libgcc.patch
index 1d07efed80..1d07efed80 100644
--- a/toolchain/gcc/patches/7.4.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/7.5.0/850-use_shared_libgcc.patch
diff --git a/toolchain/gcc/patches/7.4.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/7.5.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/7.4.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/7.5.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/7.4.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/7.5.0/870-ppc_no_crtsavres.patch
index 1b448eb5b2..1b448eb5b2 100644
--- a/toolchain/gcc/patches/7.4.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/7.5.0/870-ppc_no_crtsavres.patch
diff --git a/toolchain/gcc/patches/7.4.0/881-no_tm_section.patch b/toolchain/gcc/patches/7.5.0/881-no_tm_section.patch
index a58dc27e64..a58dc27e64 100644
--- a/toolchain/gcc/patches/7.4.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/7.5.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/7.4.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/7.5.0/900-bad-mips16-crt.patch
index f5cc0a74ee..f5cc0a74ee 100644
--- a/toolchain/gcc/patches/7.4.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/7.5.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/7.4.0/910-mbsd_multi.patch b/toolchain/gcc/patches/7.5.0/910-mbsd_multi.patch
index f19007ea30..f19007ea30 100644
--- a/toolchain/gcc/patches/7.4.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/7.5.0/910-mbsd_multi.patch
diff --git a/toolchain/gcc/patches/7.4.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/7.5.0/920-specs_nonfatal_getenv.patch
index a0fdc5f165..a0fdc5f165 100644
--- a/toolchain/gcc/patches/7.4.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/7.5.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/7.4.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/7.5.0/930-fix-mips-noexecstack.patch
index 5affd6f92d..5affd6f92d 100644
--- a/toolchain/gcc/patches/7.4.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/7.5.0/930-fix-mips-noexecstack.patch
diff --git a/toolchain/gcc/patches/7.4.0/931-libffi-fix-MIPS-softfloat-build-issue.patch b/toolchain/gcc/patches/7.5.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
index 9d436efc18..9d436efc18 100644
--- a/toolchain/gcc/patches/7.4.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
+++ b/toolchain/gcc/patches/7.5.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
diff --git a/toolchain/gcc/patches/7.4.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/7.5.0/940-no-clobber-stamp-bits.patch
index 6a4d54aaa2..6a4d54aaa2 100644
--- a/toolchain/gcc/patches/7.4.0/940-no-clobber-stamp-bits.patch
+++ b/toolchain/gcc/patches/7.5.0/940-no-clobber-stamp-bits.patch
diff --git a/toolchain/gcc/patches/7.4.0/950-cpp_file_path_translation.patch b/toolchain/gcc/patches/7.5.0/950-cpp_file_path_translation.patch
index cd30cb2014..cd30cb2014 100644
--- a/toolchain/gcc/patches/7.4.0/950-cpp_file_path_translation.patch
+++ b/toolchain/gcc/patches/7.5.0/950-cpp_file_path_translation.patch
diff --git a/toolchain/gcc/patches/7.4.0/960-gotools-fix-compilation-when-making-cross-compiler.patch b/toolchain/gcc/patches/7.5.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
index 556fa16473..556fa16473 100644
--- a/toolchain/gcc/patches/7.4.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
+++ b/toolchain/gcc/patches/7.5.0/960-gotools-fix-compilation-when-making-cross-compiler.patch