aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-01-12 10:15:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-01-12 10:15:20 +0000
commite3a21eb9f87988f26d0871ad050f05f8d88ddcc7 (patch)
tree5129e84b9b78f1f411ec0e58df1d58e8bc480dc5 /toolchain/gcc
parent39195e3a25328367918fc1a8b61d769b863da0f8 (diff)
downloadupstream-e3a21eb9f87988f26d0871ad050f05f8d88ddcc7.tar.gz
upstream-e3a21eb9f87988f26d0871ad050f05f8d88ddcc7.tar.bz2
upstream-e3a21eb9f87988f26d0871ad050f05f8d88ddcc7.zip
gcc: always explicitly link against libstdc++, fixes build errors on some hosts that refuse to link it in implicitly (should fix #10587)
SVN-Revision: 29721
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 75ad8af6ff..8b74533350 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -107,7 +107,7 @@ GCC_CONFIGURE:= \
--disable-multilib \
--disable-nls \
$(GRAPHITE_CONFIGURE) \
- $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
+ --with-host-libstdcxx=-lstdc++ \
$(SOFT_FLOAT_CONFIG_OPTION) \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
$(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \