aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2017-05-30 15:10:02 +0800
committerFelix Fietkau <nbd@nbd.name>2017-05-30 09:32:10 +0200
commitc87aa0d7ca8f2dcd3cf559a4933fef3cb44f7a21 (patch)
tree5e6b275a9374f420612ec82ddd0c7861851b2682 /toolchain/gcc
parent677356174845e8453448843fa64bd92cab584d25 (diff)
downloadupstream-c87aa0d7ca8f2dcd3cf559a4933fef3cb44f7a21.tar.gz
upstream-c87aa0d7ca8f2dcd3cf559a4933fef3cb44f7a21.tar.bz2
upstream-c87aa0d7ca8f2dcd3cf559a4933fef3cb44f7a21.zip
toolchain/gcc: fix --with-isl path
This fixes GCC 7 compilation when GRAPHITE is selected. The path is replaced with $(TOOLCHAIN_DIR), while it should be $(STAGING_DIR_HOST). To keep in sync with the path of gmp, mpfr and mpc, I'm using $(TOPDIR)/staging_dir/host. Fixes: f62f4b3c5c9d ("build: stop overriding STAGING_DIR_HOST for toolchain build") Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 55ae1a2c09..b28d3ce36b 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -91,9 +91,9 @@ ifdef CONFIG_INSTALL_GCCGO
endif
ifdef CONFIG_GCC_USE_GRAPHITE
- GRAPHITE_CONFIGURE=--with-isl=$(HOST_BUILD_PREFIX)
+ GRAPHITE_CONFIGURE:= --with-isl=$(TOPDIR)/staging_dir/host
else
- GRAPHITE_CONFIGURE=--without-isl --without-cloog
+ GRAPHITE_CONFIGURE:= --without-isl --without-cloog
endif
GCC_CONFIGURE:= \