aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2020-07-08 06:41:21 +0800
committerPetr Štetiar <ynezz@true.cz>2020-07-11 13:33:28 +0200
commitbf540f333ce6426b353d1f025455c1dfc0d089f6 (patch)
treee2427565de41d74b581cba7dfed5a23f55f27742 /toolchain/gcc
parentd0b25301d3d86c4b011ca45af67abc90d7373f30 (diff)
downloadupstream-bf540f333ce6426b353d1f025455c1dfc0d089f6.tar.gz
upstream-bf540f333ce6426b353d1f025455c1dfc0d089f6.tar.bz2
upstream-bf540f333ce6426b353d1f025455c1dfc0d089f6.zip
toolchain/gcc: Add GCC 10.1.0 config
Add needed config changes and tarball hash for new GCC version. Signed-off-by: Syrone Wong <wong.syrone@gmail.com> [added missing commit description] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.in3
-rw-r--r--toolchain/gcc/Config.version5
-rw-r--r--toolchain/gcc/common.mk4
3 files changed, 12 insertions, 0 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 4b2ba7aaae..1aadae6839 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -19,6 +19,9 @@ choice
config GCC_USE_VERSION_9
bool "gcc 9.x"
+
+ config GCC_USE_VERSION_10
+ bool "gcc 10.x"
endchoice
config GCC_USE_GRAPHITE
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 6fbc6d9804..ccc7b273fa 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -10,11 +10,16 @@ config GCC_VERSION_9
default y if GCC_USE_VERSION_9
bool
+config GCC_VERSION_10
+ default y if GCC_USE_VERSION_10
+ bool
+
config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5
default "7.5.0" if GCC_VERSION_7
default "9.3.0" if GCC_VERSION_9
+ default "10.1.0" if GCC_VERSION_10
default "8.4.0"
config GCC_USE_IREMAP
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index ec3ea8fff1..eb0ddbf2d9 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -44,6 +44,10 @@ ifeq ($(PKG_VERSION),9.3.0)
PKG_HASH:=71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
endif
+ifeq ($(PKG_VERSION),10.1.0)
+ PKG_HASH:=b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2
+endif
+
PATCH_DIR=../patches/$(GCC_VERSION)
BUGURL=http://bugs.openwrt.org/