aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-08-19 01:02:43 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-19 01:02:43 +0200
commitb8b7d4cbca67bdba3f3d31e4da99fc850cb61168 (patch)
tree55ce57f17edd63adf3c18b2f3e1ecfe75b81b63d /toolchain/gcc
parentc262daf308e0f0bd93bb5c5ee6238773935079ee (diff)
downloadupstream-b8b7d4cbca67bdba3f3d31e4da99fc850cb61168.tar.gz
upstream-b8b7d4cbca67bdba3f3d31e4da99fc850cb61168.tar.bz2
upstream-b8b7d4cbca67bdba3f3d31e4da99fc850cb61168.zip
gcc: Update gcc 9.X to version 9.2.0
This updates the GCC version 9.X to version 9.2.0. The removed patches are applied upstream. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Config.version2
-rw-r--r--toolchain/gcc/common.mk4
-rw-r--r--toolchain/gcc/patches/9.1.0/970-recompute-dom-fast-queries-before-vn.patch38
-rw-r--r--toolchain/gcc/patches/9.1.0/975-g++-ICE-with-generic-lambda.patch43
-rw-r--r--toolchain/gcc/patches/9.2.0/002-case_insensitive.patch (renamed from toolchain/gcc/patches/9.1.0/002-case_insensitive.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/010-documentation.patch (renamed from toolchain/gcc/patches/9.1.0/010-documentation.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/110-Fix-MIPS-PR-84790.patch (renamed from toolchain/gcc/patches/9.1.0/110-Fix-MIPS-PR-84790.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/230-musl_libssp.patch (renamed from toolchain/gcc/patches/9.1.0/230-musl_libssp.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/300-mips_Os_cpu_rtx_cost_model.patch (renamed from toolchain/gcc/patches/9.1.0/300-mips_Os_cpu_rtx_cost_model.patch)2
-rw-r--r--toolchain/gcc/patches/9.2.0/810-arm-softfloat-libgcc.patch (renamed from toolchain/gcc/patches/9.1.0/810-arm-softfloat-libgcc.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/820-libgcc_pic.patch (renamed from toolchain/gcc/patches/9.1.0/820-libgcc_pic.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/840-armv4_pass_fix-v4bx_to_ld.patch (renamed from toolchain/gcc/patches/9.1.0/840-armv4_pass_fix-v4bx_to_ld.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/850-use_shared_libgcc.patch (renamed from toolchain/gcc/patches/9.1.0/850-use_shared_libgcc.patch)2
-rw-r--r--toolchain/gcc/patches/9.2.0/851-libgcc_no_compat.patch (renamed from toolchain/gcc/patches/9.1.0/851-libgcc_no_compat.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/870-ppc_no_crtsavres.patch (renamed from toolchain/gcc/patches/9.1.0/870-ppc_no_crtsavres.patch)2
-rw-r--r--toolchain/gcc/patches/9.2.0/881-no_tm_section.patch (renamed from toolchain/gcc/patches/9.1.0/881-no_tm_section.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/900-bad-mips16-crt.patch (renamed from toolchain/gcc/patches/9.1.0/900-bad-mips16-crt.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/910-mbsd_multi.patch (renamed from toolchain/gcc/patches/9.1.0/910-mbsd_multi.patch)4
-rw-r--r--toolchain/gcc/patches/9.2.0/920-specs_nonfatal_getenv.patch (renamed from toolchain/gcc/patches/9.1.0/920-specs_nonfatal_getenv.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/930-fix-mips-noexecstack.patch (renamed from toolchain/gcc/patches/9.1.0/930-fix-mips-noexecstack.patch)2
-rw-r--r--toolchain/gcc/patches/9.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch (renamed from toolchain/gcc/patches/9.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch)0
-rw-r--r--toolchain/gcc/patches/9.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch (renamed from toolchain/gcc/patches/9.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch)0
22 files changed, 9 insertions, 90 deletions
diff --git a/toolchain/gcc/Config.version b/toolchain/gcc/Config.version
index 2a9dc289db..d9732b3e0d 100644
--- a/toolchain/gcc/Config.version
+++ b/toolchain/gcc/Config.version
@@ -20,5 +20,5 @@ config GCC_VERSION
string
default "5.5.0" if GCC_VERSION_5
default "8.3.0" if GCC_VERSION_8
- default "9.1.0" if GCC_VERSION_9
+ default "9.2.0" if GCC_VERSION_9
default "7.4.0"
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index fd48894953..883d2a0b4a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -40,8 +40,8 @@ ifeq ($(PKG_VERSION),8.3.0)
PKG_HASH:=64baadfe6cc0f4947a84cb12d7f0dfaf45bb58b7e92461639596c21e02d97d2c
endif
-ifeq ($(PKG_VERSION),9.1.0)
- PKG_HASH:=79a66834e96a6050d8fe78db2c3b32fb285b230b855d0a66288235bc04b327a0
+ifeq ($(PKG_VERSION),9.2.0)
+ PKG_HASH:=ea6ef08f121239da5695f76c9b33637a118dcf63e24164422231917fa61fb206
endif
PATCH_DIR=../patches/$(GCC_VERSION)
diff --git a/toolchain/gcc/patches/9.1.0/970-recompute-dom-fast-queries-before-vn.patch b/toolchain/gcc/patches/9.1.0/970-recompute-dom-fast-queries-before-vn.patch
deleted file mode 100644
index 9c2fe23507..0000000000
--- a/toolchain/gcc/patches/9.1.0/970-recompute-dom-fast-queries-before-vn.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From f36b864c7d84b36883c6190c83b31c0a8c15172b Mon Sep 17 00:00:00 2001
-From: rguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>
-Date: Fri, 3 May 2019 11:22:33 +0000
-Subject: [PATCH] 2019-05-03 Richard Biener <rguenther@suse.de>
-
- PR tree-optimization/90316
- * tree-ssa-pre.c (pass_pre::execute): Re-compute DOM fast queries
- before running VN.
-
-
-git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-9-branch@270849 138bc75d-0d04-0410-961f-82ee72b054a4
----
- gcc/ChangeLog | 6 ++++++
- gcc/tree-ssa-pre.c | 1 +
- 2 files changed, 7 insertions(+)
-
---- a/gcc/ChangeLog
-+++ b/gcc/ChangeLog
-@@ -1,3 +1,9 @@
-+2019-05-03 Richard Biener <rguenther@suse.de>
-+
-+ PR tree-optimization/90316
-+ * tree-ssa-pre.c (pass_pre::execute): Re-compute DOM fast queries
-+ before running VN.
-+
- 2019-05-03 Release Manager
-
- * GCC 9.1.0 released.
---- a/gcc/tree-ssa-pre.c
-+++ b/gcc/tree-ssa-pre.c
-@@ -4197,6 +4197,7 @@ pass_pre::execute (function *fun)
- loop_optimizer_init (LOOPS_NORMAL);
- split_critical_edges ();
- scev_initialize ();
-+ calculate_dominance_info (CDI_DOMINATORS);
-
- run_rpo_vn (VN_WALK);
-
diff --git a/toolchain/gcc/patches/9.1.0/975-g++-ICE-with-generic-lambda.patch b/toolchain/gcc/patches/9.1.0/975-g++-ICE-with-generic-lambda.patch
deleted file mode 100644
index 2adc9cfabe..0000000000
--- a/toolchain/gcc/patches/9.1.0/975-g++-ICE-with-generic-lambda.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 7a1606168f60622f73a7dd90778e2a148a2c520c Mon Sep 17 00:00:00 2001
-From: mpolacek <mpolacek@138bc75d-0d04-0410-961f-82ee72b054a4>
-Date: Mon, 6 May 2019 17:08:08 +0000
-Subject: [PATCH] PR c++/90265 - ICE with generic lambda. * pt.c
- (tsubst_copy_and_build): Use a dedicated variable for the last
- element in the vector.
-
- * g++.dg/cpp1y/lambda-generic-90265.C: New test.
-
-
-git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-9-branch@270919 138bc75d-0d04-0410-961f-82ee72b054a4
----
- gcc/cp/ChangeLog | 6 ++++++
- gcc/cp/pt.c | 3 ++-
- gcc/testsuite/ChangeLog | 5 +++++
- gcc/testsuite/g++.dg/cpp1y/lambda-generic-90265.C | 4 ++++
- 4 files changed, 17 insertions(+), 1 deletion(-)
- create mode 100644 gcc/testsuite/g++.dg/cpp1y/lambda-generic-90265.C
-
---- a/gcc/cp/ChangeLog
-+++ b/gcc/cp/ChangeLog
-@@ -1,3 +1,9 @@
-+2019-05-06 Marek Polacek <polacek@redhat.com>
-+
-+ PR c++/90265 - ICE with generic lambda.
-+ * pt.c (tsubst_copy_and_build): Use a dedicated variable for the last
-+ element in the vector.
-+
- 2019-05-03 Release Manager
-
- * GCC 9.1.0 released.
---- a/gcc/cp/pt.c
-+++ b/gcc/cp/pt.c
-@@ -18881,7 +18881,8 @@ tsubst_copy_and_build (tree t,
- if (thisarg)
- {
- /* Shift the other args over to make room. */
-- vec_safe_push (call_args, (*call_args)[nargs-1]);
-+ tree last = (*call_args)[nargs - 1];
-+ vec_safe_push (call_args, last);
- for (int i = nargs-1; i > 0; --i)
- (*call_args)[i] = (*call_args)[i-1];
- (*call_args)[0] = thisarg;
diff --git a/toolchain/gcc/patches/9.1.0/002-case_insensitive.patch b/toolchain/gcc/patches/9.2.0/002-case_insensitive.patch
index 3442076d7d..3442076d7d 100644
--- a/toolchain/gcc/patches/9.1.0/002-case_insensitive.patch
+++ b/toolchain/gcc/patches/9.2.0/002-case_insensitive.patch
diff --git a/toolchain/gcc/patches/9.1.0/010-documentation.patch b/toolchain/gcc/patches/9.2.0/010-documentation.patch
index 2ceb997960..2ceb997960 100644
--- a/toolchain/gcc/patches/9.1.0/010-documentation.patch
+++ b/toolchain/gcc/patches/9.2.0/010-documentation.patch
diff --git a/toolchain/gcc/patches/9.1.0/110-Fix-MIPS-PR-84790.patch b/toolchain/gcc/patches/9.2.0/110-Fix-MIPS-PR-84790.patch
index c7e60e3157..c7e60e3157 100644
--- a/toolchain/gcc/patches/9.1.0/110-Fix-MIPS-PR-84790.patch
+++ b/toolchain/gcc/patches/9.2.0/110-Fix-MIPS-PR-84790.patch
diff --git a/toolchain/gcc/patches/9.1.0/230-musl_libssp.patch b/toolchain/gcc/patches/9.2.0/230-musl_libssp.patch
index 41d75b0206..41d75b0206 100644
--- a/toolchain/gcc/patches/9.1.0/230-musl_libssp.patch
+++ b/toolchain/gcc/patches/9.2.0/230-musl_libssp.patch
diff --git a/toolchain/gcc/patches/9.1.0/300-mips_Os_cpu_rtx_cost_model.patch b/toolchain/gcc/patches/9.2.0/300-mips_Os_cpu_rtx_cost_model.patch
index 8d7bbb93b4..5caa852a16 100644
--- a/toolchain/gcc/patches/9.1.0/300-mips_Os_cpu_rtx_cost_model.patch
+++ b/toolchain/gcc/patches/9.2.0/300-mips_Os_cpu_rtx_cost_model.patch
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/gcc/config/mips/mips.c
+++ b/gcc/config/mips/mips.c
-@@ -19970,7 +19970,7 @@ mips_option_override (void)
+@@ -19994,7 +19994,7 @@ mips_option_override (void)
flag_pcc_struct_return = 0;
/* Decide which rtx_costs structure to use. */
diff --git a/toolchain/gcc/patches/9.1.0/810-arm-softfloat-libgcc.patch b/toolchain/gcc/patches/9.2.0/810-arm-softfloat-libgcc.patch
index 5c9d86aead..5c9d86aead 100644
--- a/toolchain/gcc/patches/9.1.0/810-arm-softfloat-libgcc.patch
+++ b/toolchain/gcc/patches/9.2.0/810-arm-softfloat-libgcc.patch
diff --git a/toolchain/gcc/patches/9.1.0/820-libgcc_pic.patch b/toolchain/gcc/patches/9.2.0/820-libgcc_pic.patch
index 0a316d35bf..0a316d35bf 100644
--- a/toolchain/gcc/patches/9.1.0/820-libgcc_pic.patch
+++ b/toolchain/gcc/patches/9.2.0/820-libgcc_pic.patch
diff --git a/toolchain/gcc/patches/9.1.0/840-armv4_pass_fix-v4bx_to_ld.patch b/toolchain/gcc/patches/9.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
index 18aa021b93..18aa021b93 100644
--- a/toolchain/gcc/patches/9.1.0/840-armv4_pass_fix-v4bx_to_ld.patch
+++ b/toolchain/gcc/patches/9.2.0/840-armv4_pass_fix-v4bx_to_ld.patch
diff --git a/toolchain/gcc/patches/9.1.0/850-use_shared_libgcc.patch b/toolchain/gcc/patches/9.2.0/850-use_shared_libgcc.patch
index 895e45bfa5..a765e55a46 100644
--- a/toolchain/gcc/patches/9.1.0/850-use_shared_libgcc.patch
+++ b/toolchain/gcc/patches/9.2.0/850-use_shared_libgcc.patch
@@ -42,7 +42,7 @@ Date: Sun Feb 12 20:25:47 2012 +0000
}
--- a/gcc/config/rs6000/linux.h
+++ b/gcc/config/rs6000/linux.h
-@@ -75,6 +75,9 @@
+@@ -62,6 +62,9 @@
#undef CPP_OS_DEFAULT_SPEC
#define CPP_OS_DEFAULT_SPEC "%(cpp_os_linux)"
diff --git a/toolchain/gcc/patches/9.1.0/851-libgcc_no_compat.patch b/toolchain/gcc/patches/9.2.0/851-libgcc_no_compat.patch
index d710e40717..d710e40717 100644
--- a/toolchain/gcc/patches/9.1.0/851-libgcc_no_compat.patch
+++ b/toolchain/gcc/patches/9.2.0/851-libgcc_no_compat.patch
diff --git a/toolchain/gcc/patches/9.1.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/9.2.0/870-ppc_no_crtsavres.patch
index 93c6a4b123..06bb0efda2 100644
--- a/toolchain/gcc/patches/9.1.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/9.2.0/870-ppc_no_crtsavres.patch
@@ -1,6 +1,6 @@
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
-@@ -24349,7 +24349,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -24365,7 +24365,7 @@ rs6000_savres_strategy (rs6000_stack_t *
/* Define cutoff for using out-of-line functions to save registers. */
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
{
diff --git a/toolchain/gcc/patches/9.1.0/881-no_tm_section.patch b/toolchain/gcc/patches/9.2.0/881-no_tm_section.patch
index fab5db3be5..fab5db3be5 100644
--- a/toolchain/gcc/patches/9.1.0/881-no_tm_section.patch
+++ b/toolchain/gcc/patches/9.2.0/881-no_tm_section.patch
diff --git a/toolchain/gcc/patches/9.1.0/900-bad-mips16-crt.patch b/toolchain/gcc/patches/9.2.0/900-bad-mips16-crt.patch
index dd6e9dc889..dd6e9dc889 100644
--- a/toolchain/gcc/patches/9.1.0/900-bad-mips16-crt.patch
+++ b/toolchain/gcc/patches/9.2.0/900-bad-mips16-crt.patch
diff --git a/toolchain/gcc/patches/9.1.0/910-mbsd_multi.patch b/toolchain/gcc/patches/9.2.0/910-mbsd_multi.patch
index e28cc2ac6b..3d47bf16ad 100644
--- a/toolchain/gcc/patches/9.1.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/9.2.0/910-mbsd_multi.patch
@@ -40,7 +40,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
case OPT_fconstant_string_class_:
constant_string_class_name = arg;
break;
-@@ -1134,6 +1143,47 @@ c_common_init (void)
+@@ -1138,6 +1147,47 @@ c_common_init (void)
return false;
}
@@ -134,7 +134,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
@opindex Wno-stack-protector
--- a/gcc/opts.c
+++ b/gcc/opts.c
-@@ -2321,6 +2321,9 @@ common_handle_option (struct gcc_options
+@@ -2314,6 +2314,9 @@ common_handle_option (struct gcc_options
/* Currently handled in a prescan. */
break;
diff --git a/toolchain/gcc/patches/9.1.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/9.2.0/920-specs_nonfatal_getenv.patch
index db27950de8..db27950de8 100644
--- a/toolchain/gcc/patches/9.1.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/9.2.0/920-specs_nonfatal_getenv.patch
diff --git a/toolchain/gcc/patches/9.1.0/930-fix-mips-noexecstack.patch b/toolchain/gcc/patches/9.2.0/930-fix-mips-noexecstack.patch
index f6c6ba9951..95d13abad0 100644
--- a/toolchain/gcc/patches/9.1.0/930-fix-mips-noexecstack.patch
+++ b/toolchain/gcc/patches/9.2.0/930-fix-mips-noexecstack.patch
@@ -48,7 +48,7 @@ sellcey@mips.com
--- a/gcc/config/mips/mips.c
+++ b/gcc/config/mips/mips.c
-@@ -22798,6 +22798,9 @@ mips_starting_frame_offset (void)
+@@ -22822,6 +22822,9 @@ mips_starting_frame_offset (void)
#undef TARGET_STARTING_FRAME_OFFSET
#define TARGET_STARTING_FRAME_OFFSET mips_starting_frame_offset
diff --git a/toolchain/gcc/patches/9.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch b/toolchain/gcc/patches/9.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
index fb4cb1533a..fb4cb1533a 100644
--- a/toolchain/gcc/patches/9.1.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
+++ b/toolchain/gcc/patches/9.2.0/931-libffi-fix-MIPS-softfloat-build-issue.patch
diff --git a/toolchain/gcc/patches/9.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch b/toolchain/gcc/patches/9.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
index b1d7576328..b1d7576328 100644
--- a/toolchain/gcc/patches/9.1.0/960-gotools-fix-compilation-when-making-cross-compiler.patch
+++ b/toolchain/gcc/patches/9.2.0/960-gotools-fix-compilation-when-making-cross-compiler.patch